summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-04 17:53:14 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-04 17:53:14 +0000
commit388f52ad728eb15049cf373eec0bf20014f3a551 (patch)
treeeb76391d8111bd3e24ce251eaaa251499d7224c5 /sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild
parentpkg_postinstall -> pkg_postinst (diff)
downloadhistorical-388f52ad728eb15049cf373eec0bf20014f3a551.tar.gz
historical-388f52ad728eb15049cf373eec0bf20014f3a551.tar.bz2
historical-388f52ad728eb15049cf373eec0bf20014f3a551.zip
Added patches for the CAN-2004-0133, CAN-2004-0181, CAN-2004-0394, and CAN-2004-0427 vulnerabilities. Bug #47881. Old versions of sources removed. QA: Fixed ebuild.badheader; moved "Submitted by" data to the ChangeLog.
Diffstat (limited to 'sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild')
-rw-r--r--sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild b/sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild
new file mode 100644
index 000000000000..f5871252c659
--- /dev/null
+++ b/sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/wolk-sources/wolk-sources-4.11-r4.ebuild,v 1.1 2004/06/04 17:53:14 plasmaroo Exp $
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel eutils
+IUSE=""
+OKV=2.4.20
+KV=${OKV}-wolk4.11s-${PR}
+EXTRAVERSION=-wolk4.11s-${PR}
+
+S=${WORKDIR}/linux-${KV}
+DESCRIPTION="Working Overloaded Linux Kernel (Server-Edition)"
+
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~mips"
+
+SRC_PATH="mirror://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://sourceforge/wolk/linux-${OKV}-wolk4.10s.patch.bz2
+ mirror://sourceforge/wolk/linux-${OKV}-wolk4.10s-to-4.11s.patch.bz2"
+
+SLOT="${KV}"
+HOMEPAGE="http://wolk.sourceforge.net http://www.kernel.org"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2 || die
+ mv linux-${OKV} linux-${KV} || die
+ cd ${WORKDIR}/linux-${KV} || die
+ epatch ${DISTDIR}/linux-${OKV}-wolk4.10s.patch.bz2 || die
+ epatch ${DISTDIR}/linux-${OKV}-wolk4.10s-to-4.11s.patch.bz2 || die
+
+ epatch ${FILESDIR}/${PN}.CAN-2003-0985.patch || die "Failed to patch mremap() vulnerability!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0109.patch || die "Failed to add the CAN-2004-0109 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0133.patch || die "Failed to add the CAN-2004-0133 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0177.patch || die "Failed to add the CAN-2004-0177 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0178.patch || die "Failed to add the CAN-2004-0178 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0181.patch || die "Failed to add the CAN-2004-0181 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0427.patch || die "Failed to add the CAN-2004-0427 patch!"
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is the base WOLK 4.11 Server Edition with all"
+ einfo "recent security fixes, but no workstation patches."
+ einfo
+}