summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-02-28 04:04:16 +0000
committerBob Johnson <livewire@gentoo.org>2003-02-28 04:04:16 +0000
commita7ffc884512667963d2ee0fb71bf5cb78e40f4d9 (patch)
treeb8f50d9cac7d2aaefcb3e1ad98e82a771f0ff0f8 /sys-kernel/gs-sources
parenttimeout fix (diff)
downloadhistorical-a7ffc884512667963d2ee0fb71bf5cb78e40f4d9.tar.gz
historical-a7ffc884512667963d2ee0fb71bf5cb78e40f4d9.tar.bz2
historical-a7ffc884512667963d2ee0fb71bf5cb78e40f4d9.zip
new 2.4.21_pre5 ebuild
Diffstat (limited to 'sys-kernel/gs-sources')
-rw-r--r--sys-kernel/gs-sources/ChangeLog8
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre52
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.21_pre5.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index c48b126d9a17..19a77388e4b5 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.6 2003/02/18 20:49:55 livewire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.7 2003/02/28 04:04:16 livewire Exp $
+*gs-sources-2.4.21_pre5 (27 Feb 2003)
+
+ 27 Feb 2003: Bob Johnson <livewire@gentoo.org>
+
+ - bumped to 2.4.21_pre5
+
*gs-sources-2.4.21_pre4 (18 Feb 2003)
18 Feb 2003: Bob Johnson <livewire@gentoo.org>
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre5 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre5
new file mode 100644
index 000000000000..dce615570c4b
--- /dev/null
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre5
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 c40e1a26c03d5acce392a060da31a246 patches-2.4.21_pre5-gss.tar.bz2 4728157
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.21_pre5.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.21_pre5.ebuild
new file mode 100644
index 000000000000..b9ef27ed5427
--- /dev/null
+++ b/sys-kernel/gs-sources/gs-sources-2.4.21_pre5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.21_pre5.ebuild,v 1.1 2003/02/28 04:04:16 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-pre5-gss
+KV=2.4.21_pre5-gss
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="This kernel will hopefully stay up to date and stable for livecd"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}