summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-02-18 20:49:55 +0000
committerBob Johnson <livewire@gentoo.org>2003-02-18 20:49:55 +0000
commit3ec7c9b156c013ec4a89b759509ca1cff2c4d744 (patch)
tree720b50a41870f043504a680663e92f3aef493d92 /sys-kernel/gs-sources
parentcleanup (diff)
downloadhistorical-3ec7c9b156c013ec4a89b759509ca1cff2c4d744.tar.gz
historical-3ec7c9b156c013ec4a89b759509ca1cff2c4d744.tar.bz2
historical-3ec7c9b156c013ec4a89b759509ca1cff2c4d744.zip
bumped version to 2.4.21_pre4
Diffstat (limited to 'sys-kernel/gs-sources')
-rw-r--r--sys-kernel/gs-sources/ChangeLog8
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre42
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.21_pre4.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index bd20c6c43156..c48b126d9a17 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.5 2003/02/12 09:16:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.6 2003/02/18 20:49:55 livewire Exp $
+
+*gs-sources-2.4.21_pre4 (18 Feb 2003)
+
+ 18 Feb 2003: Bob Johnson <livewire@gentoo.org>
+
+ - bumped to 2.4.21_pre4
*gs-sources-2.4.21_pre3-r3 (24 Jan 2003)
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre4 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre4
new file mode 100644
index 000000000000..a3eaf3a47783
--- /dev/null
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre4
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 7d9869a1a14777f6626cbaf0516592d9 patches-2.4.21_pre4-gss.tar.bz2 4036426
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.21_pre4.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.21_pre4.ebuild
new file mode 100644
index 000000000000..21a9ed8ab958
--- /dev/null
+++ b/sys-kernel/gs-sources/gs-sources-2.4.21_pre4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.21_pre4.ebuild,v 1.1 2003/02/18 20:49:55 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-pre4-gss
+KV=2.4.21_pre4-gss
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="This kernel will hopefully stay up to date and stable for livecd"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}