summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-01-24 19:02:04 +0000
committerBob Johnson <livewire@gentoo.org>2003-01-24 19:02:04 +0000
commit03d821e9613f3c61146818d84f6df92ca2e9c709 (patch)
tree556dbea1d5a08fd7cb9fa110ca5d8efb9303e51f /sys-kernel/gs-sources
parentremoving kde 3.1 rc5. we have rc6, and final (=rc7) should be released in a f... (diff)
downloadhistorical-03d821e9613f3c61146818d84f6df92ca2e9c709.tar.gz
historical-03d821e9613f3c61146818d84f6df92ca2e9c709.tar.bz2
historical-03d821e9613f3c61146818d84f6df92ca2e9c709.zip
new ebuild
Diffstat (limited to 'sys-kernel/gs-sources')
-rw-r--r--sys-kernel/gs-sources/ChangeLog14
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre3-r32
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.21_pre3-r3.ebuild68
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index f8f6dde52865..fb78a3a9d74e 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.3 2003/01/18 06:45:04 livewire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.4 2003/01/24 19:02:04 livewire Exp $
+
+*gs-sources-2.4.21_pre3-r3 (24 Jan 2003)
+
+ 24 Jan 2003: Bob Johnson <livewire@gentoo.org>
+
+ - updated acpi (Jan 23, 2003) with compile fixes
+ - updated aic79xx (Jan 22, 2003)
+ - bcm4400 nic drivers added
+ - bcm5700 nic drivers added
+ - Thinkpad support added
+ - experimental hpt370 fix
+ - Sim710 compile fixes
*gs-sources-2.4.21_pre3-r2 (18 Jan 2003)
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre3-r3 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre3-r3
new file mode 100644
index 000000000000..f55331d9fb08
--- /dev/null
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre3-r3
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 e2f4595b98aafa7cab3f6916f5683af5 patches-2.4.21_pre3-gss-r3.tar.bz2 4858151
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.21_pre3-r3.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.21_pre3-r3.ebuild
new file mode 100644
index 000000000000..2bf20316a523
--- /dev/null
+++ b/sys-kernel/gs-sources/gs-sources-2.4.21_pre3-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.21_pre3-r3.ebuild,v 1.1 2003/01/24 19:02:04 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-pre3-gss-r3
+KV=2.4.21_pre3-gss-r3
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="This kernel will hopefully stay up to date and stable for livecd"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+
+}