summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-04-06 04:00:22 +0000
committerZack Welch <zwelch@gentoo.org>2003-04-06 04:00:22 +0000
commitfe9757f0aea99c5c403432b2e07cafd6b112642d (patch)
treeaf93bf89fc0b5e491f6f10838e8ed99a59556dfb /sys-kernel/arm-sources
parent~x86 -> x86 and added ~ppc (diff)
downloadhistorical-fe9757f0aea99c5c403432b2e07cafd6b112642d.tar.gz
historical-fe9757f0aea99c5c403432b2e07cafd6b112642d.tar.bz2
historical-fe9757f0aea99c5c403432b2e07cafd6b112642d.zip
bump to latest netwinder kernel version
Diffstat (limited to 'sys-kernel/arm-sources')
-rw-r--r--sys-kernel/arm-sources/ChangeLog7
-rw-r--r--sys-kernel/arm-sources/arm-sources-2.4.19-r1.ebuild95
-rw-r--r--sys-kernel/arm-sources/files/digest-arm-sources-2.4.19-r14
3 files changed, 105 insertions, 1 deletions
diff --git a/sys-kernel/arm-sources/ChangeLog b/sys-kernel/arm-sources/ChangeLog
index 263d2bd6d40d..b77b04413bbd 100644
--- a/sys-kernel/arm-sources/ChangeLog
+++ b/sys-kernel/arm-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/arm-sources
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-sources/ChangeLog,v 1.3 2003/04/05 01:00:55 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-sources/ChangeLog,v 1.4 2003/04/06 04:00:22 zwelch Exp $
+
+*arm-sources-2.4.19-r1 (05 Apr 2003)
+
+ 05 Apr 2003; Zach Welch <zwelch@gentoo.org> arm-sources-2.4.19-r1.ebuild:
+ bump to latest netwinder kernel version
*arm-sources-2.4.19 (24 Feb 2003)
diff --git a/sys-kernel/arm-sources/arm-sources-2.4.19-r1.ebuild b/sys-kernel/arm-sources/arm-sources-2.4.19-r1.ebuild
new file mode 100644
index 000000000000..7765885ac9c7
--- /dev/null
+++ b/sys-kernel/arm-sources/arm-sources-2.4.19-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-sources/arm-sources-2.4.19-r1.ebuild,v 1.1 2003/04/06 04:00:22 zwelch Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+IUSE=""
+DEPEND=""
+LICENSE="GPL-2"
+
+ETYPE="sources"
+inherit kernel
+
+#####
+# move to arm profile
+
+# this specifies the main ARM kernel patch level
+ARM_PATCH_SUFFIX="-rmk7"
+
+######
+# move to ${PORTDIR}/subarch.eclass
+# then move to ${PORTDIR}/profiles/profile-arm-1.4/netwinder/subarch.conf
+
+# this specifies the SUBARCH kernel patch level and download location
+# currently, only netwinder supported
+SUBARCH_KERNEL_SUFFIX="-nw1"
+SUBARCH_KERNEL_URLBASE="\
+ ftp://ftp.netwinder.org/users/r/ralphs/kernel/beta"
+SUBARCH_KERNEL_HOMEPAGE="http://www.netwinder.org/"
+
+#####
+
+# set the kernel version now
+OKV=2.4.19
+EXTRAVERSION="${ARM_PATCH_SUFFIX}${SUBARCH_KERNEL_SUFFIX}"
+KV="${OKV}${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
+
+# this is the main rmk ARM Kernel Patch
+ARM_KERNEL_PATCH="patch-${OKV}${ARM_PATCH_SUFFIX}"
+# this is the kernel patch for SUBARCH
+[ -n "${SUBARCH_KERNEL_SUFFIX}" ] && \
+ SUBARCH_KERNEL_PATCH="${ARM_KERNEL_PATCH}${SUBARCH_KERNEL_SUFFIX}" || \
+ SUBARCH_KERNEL_PATCH=""
+
+# What's in this kernel?
+# INCLUDED:
+# stock 2.4.19 kernel sources
+# rmk patches for armlinux support
+
+DESCRIPTION="Full sources for the ARM/Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 \
+ ftp://ftp.arm.linux.org.uk/pub/armlinux/source/kernel-patches/v2.4/${ARM_KERNEL_PATCH}.bz2"
+HOMEPAGE="http://www.arm.linux.org.uk/ \
+ http://www.kernel.org/ \
+ http://www.gentoo.org/"
+
+# now fix up SRC_URI and HOMEPAGE
+if [ -n "${SUBARCH_KERNEL_PATCH}" ]; then
+ if [ -n "${SUBARCH_KERNEL_URLBASE}" ]; then
+ SRC_URI="${SRC_URI} \
+ ${SUBARCH_KERNEL_URLBASE}/${SUBARCH_KERNEL_PATCH}.gz"
+ else
+ die "${SUBARCH}: ${SUBARCH_KERNEL_PATCH} does not have a URLBASE"
+ fi
+fi
+if [ -n "${SUBARCH_KERNEL_HOMEPAGE}" ]; then
+ HOMEPAGE="${SUBARCH_KERNEL_HOMEPAGE} ${HOMEPAGE}"
+fi
+
+
+KEYWORDS="arm -hppa -x86 -ppc -sparc -alpha -mips"
+SLOT="${KV}"
+
+src_unpack() {
+ # base vanilla source
+ unpack "linux-${OKV}.tar.bz2" || die
+ mv "${WORKDIR}/linux-${OKV}" "${WORKDIR}/linux-${KV}"
+
+ # plus the Russell M. King kernel patches
+ unpack "${ARM_KERNEL_PATCH}.bz2" || die
+
+ # plus an optional SUBARCH kernel patch
+ [ -n "${SUBARCH_KERNEL_PATCH}" ] && \
+ { unpack "${SUBARCH_KERNEL_PATCH}.gz" || die; }
+
+ # do the actual patching
+ cd ${S} || die
+ epatch "${WORKDIR}/${ARM_KERNEL_PATCH}" || die
+ [ -n "${SUBARCH_KERNEL_PATCH}" ] && \
+ { epatch "${WORKDIR}/${SUBARCH_KERNEL_PATCH}" || die; }
+
+ kernel_universal_unpack
+}
+
diff --git a/sys-kernel/arm-sources/files/digest-arm-sources-2.4.19-r1 b/sys-kernel/arm-sources/files/digest-arm-sources-2.4.19-r1
new file mode 100644
index 000000000000..d921166b8778
--- /dev/null
+++ b/sys-kernel/arm-sources/files/digest-arm-sources-2.4.19-r1
@@ -0,0 +1,4 @@
+MD5 07693841adfd05a626b1fb6e919d019e /arm-sources-2.4.19-r1.ebuild 2745
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 b26f59309f1d4816e9cc5205d65aed5f patch-2.4.19-rmk7.bz2 651606
+MD5 db313e16191e97e8e8e8224a8c94685c patch-2.4.19-rmk7-nw1.gz 167115