summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-03 02:24:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-03 02:24:59 +0000
commitc7623ec5f2b4ff786c8829f0ea96103788ff70b0 (patch)
tree9e4c98bdbf1ba8001c634a0113a39d6871de3673 /sys-fs
parentfixup style (diff)
downloadhistorical-c7623ec5f2b4ff786c8829f0ea96103788ff70b0.tar.gz
historical-c7623ec5f2b4ff786c8829f0ea96103788ff70b0.tar.bz2
historical-c7623ec5f2b4ff786c8829f0ea96103788ff70b0.zip
Version bump.
Package-Manager: portage-2.1.2_rc1-r2
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog8
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4.ebuild83
-rw-r--r--sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.43
3 files changed, 93 insertions, 1 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index 574964c59b88..3212467d99d9 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.43 2006/10/12 11:03:00 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.44 2006/11/03 02:24:58 vapier Exp $
+
+*cryptsetup-luks-1.0.4 (03 Nov 2006)
+
+ 03 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+ +cryptsetup-luks-1.0.4.ebuild:
+ Version bump.
*cryptsetup-luks-1.0.3-r3 (12 Oct 2006)
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4.ebuild
new file mode 100644
index 000000000000..a14bc7cb2f7d
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4.ebuild,v 1.1 2006/11/03 02:24:58 vapier Exp $
+
+inherit linux-info eutils flag-o-matic multilib
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://luks.endorphin.org/"
+SRC_URI="http://luks.endorphin.org/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build dynamic nls selinux"
+RESTRICT="confcache"
+
+DEPEND=">=sys-fs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ selinux? ( sys-libs/libselinux )
+ !sys-fs/cryptsetup"
+
+dm-crypt_check() {
+ local CONFIG_CHECK="~DM_CRYPT"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup-luks)"
+ check_extra_config
+ echo
+}
+
+crypto_check() {
+ local CONFIG_CHECK="~CRYPTO"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup-luks)"
+ check_extra_config
+ echo
+}
+
+pkg_setup() {
+ # Bug 148390
+ if ! use build ; then
+ linux-info_pkg_setup
+ dm-crypt_check
+ crypto_check
+ fi
+}
+
+src_compile() {
+ if use dynamic ; then
+ ewarn "If you need cryptsetup for an initrd or initramfs then you"
+ ewarn "should NOT use the dynamic USE flag"
+ epause 5
+ fi
+
+ econf \
+ --sbindir=/bin \
+ $(use_enable !dynamic static) \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ rmdir "${D}"/usr/$(get_libdir)/cryptsetup
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/1.0.3-dm-crypt-start.sh dm-crypt-start.sh
+ newins "${FILESDIR}"/1.0.3-dm-crypt-stop.sh dm-crypt-stop.sh
+ newconfd "${FILESDIR}"/1.0.3-cryptfs.confd cryptfs
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "then the previous system. If you are currently using /etc/conf.d/crypfs"
+ ewarn "then you *MUST* read the new /etc/conf.d/cryptfs for instructions"
+ ewarn "on how to convert your previous cryptfs to the new syntax or your"
+ ewarn "encrypted partitions will *NOT* work."
+ einfo
+ einfo "Please see the example for configuring a LUKS mountpoint"
+ einfo "in /etc/conf.d/cryptfs"
+ einfo
+}
diff --git a/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4 b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4
new file mode 100644
index 000000000000..5941fa96ba5e
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4
@@ -0,0 +1,3 @@
+MD5 156ae6b618438ee9feeddc6c2bdc4e94 cryptsetup-luks-1.0.4.tar.bz2 306907
+RMD160 47737ab9302152a64f0e13b405c219d0166d8217 cryptsetup-luks-1.0.4.tar.bz2 306907
+SHA256 5ba6066d79443fce157b8b6081be466b4c04759cf5cd020b51a8f6cfc996e2a6 cryptsetup-luks-1.0.4.tar.bz2 306907