summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-25 01:12:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-25 01:12:36 +0000
commit7c39ab022a77ad4177518c5f0246c89824c6652a (patch)
treef3ef153e39d6ee30f96b0ee6f1ee269779222331 /sys-fs/xfsprogs
parentFixes and x86 keyword (diff)
downloadhistorical-7c39ab022a77ad4177518c5f0246c89824c6652a.tar.gz
historical-7c39ab022a77ad4177518c5f0246c89824c6652a.tar.bz2
historical-7c39ab022a77ad4177518c5f0246c89824c6652a.zip
IUSE; don't rdepend on sed; use character class in sed; error check disk io; compress docs
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog6
-rw-r--r--sys-fs/xfsprogs/Manifest4
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild15
3 files changed, 17 insertions, 8 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index 1afc7915708d..a8cd8d59bdbd 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.11 2004/04/25 08:15:13 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.12 2004/05/25 01:12:36 mr_bones_ Exp $
+
+ 24 May 2004; Michael Sterrett <mr_bones_@gentoo.org> xfsprogs-2.6.3.ebuild:
+ IUSE; don't rdepend on sed; use character class in sed; error check disk io;
+ compress docs
25 Apr 2004; Joshua Kinard <kumba@gentoo.org> xfsprogs-2.6.3.ebuild:
Tweaked the arch check to see if PLATFORM needed to be unset and added mips to
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index 668cecfc7275..a54a175650f3 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,9 +1,9 @@
-MD5 76236cf4cf2a1b6f5198a810c6b8dc33 ChangeLog 5047
+MD5 906d04cbf8fd8a0027bf650ec2da10e0 ChangeLog 5225
MD5 62537ba219966aff652bea534bb9693c xfsprogs-1.3.13.ebuild 1410
MD5 45d21b03a1db9533ef38af0653b6a1b4 xfsprogs-2.3.9.ebuild 1498
MD5 6f8ee37511ed12dc50d71b92f5a71acd xfsprogs-2.6.0.ebuild 1576
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 b46e30d0fd769a071a542e77edac7868 xfsprogs-2.6.3.ebuild 1461
+MD5 cb7e2256ae64a9d672aa0a17a23b7072 xfsprogs-2.6.3.ebuild 1567
MD5 cef66d8125681fa3a3eccf0be0698b25 files/digest-xfsprogs-1.3.13 71
MD5 0ad03e88abe9cb756d16c8b202804fbc files/digest-xfsprogs-2.3.9 70
MD5 ed760013d5e82b9e87430f596ba7b76c files/digest-xfsprogs-2.6.0 70
diff --git a/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild b/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild
index 5aabead82b98..63242d9a55b0 100644
--- a/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild,v 1.4 2004/04/27 03:21:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.6.3.ebuild,v 1.5 2004/05/25 01:12:36 mr_bones_ Exp $
inherit flag-o-matic
@@ -11,8 +11,11 @@ SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64"
+IUSE=""
-DEPEND="sys-fs/e2fsprogs
+RDEPEND="virtual/glibc
+ sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
@@ -21,7 +24,7 @@ src_unpack() {
sed -i \
-e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
-e '/^GCFLAGS/s:-O1::' \
- -e '/^PKG_[A-Z]*_DIR/s:= := $(DESTDIR):' \
+ -e '/^PKG_[[:upper:]]*_DIR/s:= := $(DESTDIR):' \
include/builddefs.in \
|| die "sed include/builddefs.in failed"
}
@@ -57,6 +60,8 @@ src_install() {
sed \
-e 's:installed=no:installed=yes:g' \
${S}/libhandle/.libs/libhandle.la \
- > ${D}/usr/lib/libhandle.la
- mv ${D}/lib/*.a ${D}/usr/lib/
+ > ${D}/usr/lib/libhandle.la \
+ || die "sed failed"
+ mv ${D}/lib/*.a ${D}/usr/lib/ || die "mv failed"
+ prepalldocs
}