summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-09-10 22:45:14 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-09-10 22:45:14 +0000
commitd937848f398f234d5d92c72296cd025841155a30 (patch)
treebe4c3fbe2303bf189f3a9c87799bf18a981e7c34 /sys-fs/udev/udev-9999.ebuild
parentStable ppc, bug #434292 (diff)
downloadhistorical-d937848f398f234d5d92c72296cd025841155a30.tar.gz
historical-d937848f398f234d5d92c72296cd025841155a30.tar.bz2
historical-d937848f398f234d5d92c72296cd025841155a30.zip
Add more information on persistent net rules and clean up ewarns.
this closes #433746 and #434626. Thanks to James Le Cuirot and Pacho Ramos. Package-Manager: portage-2.2.0_alpha125/cvs/Linux i686
Diffstat (limited to 'sys-fs/udev/udev-9999.ebuild')
-rw-r--r--sys-fs/udev/udev-9999.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index aa1a0f88aea6..789f3ecc7867 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.111 2012/09/10 21:34:44 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.112 2012/09/10 22:45:14 williamh Exp $
EAPI=4
@@ -344,18 +344,16 @@ pkg_postinst()
fi
ewarn
- ewarn "If you build an initramfs including udev, then please"
- ewarn "make sure the /usr/bin/udevadm binary gets included,"
- ewarn "and your scripts changed to use it,as it replaces the"
- ewarn "old helper apps udevinfo, udevtrigger, ..."
+ ewarn "If you build an initramfs including udev, please make sure the"
+ ewarn "/usr/bin/udevadm binary gets included, Also, change your scripts to"
+ ewarn "use it,as it replaces the old udevinfo and udevtrigger helpers."
ewarn
- ewarn "mount options for directory /dev are no longer"
- ewarn "set in /etc/udev/udev.conf, but in /etc/fstab"
- ewarn "as for other directories."
+ ewarn "mount options for /dev are no longer set in /etc/udev/udev.conf."
+ ewarn "Instead, /etc/fstab should be used. This matches other mount points."
ewarn
- ewarn "Rules for /dev/hd* devices have been removed"
+ ewarn "Rules for /dev/hd* devices have been removed."
ewarn "Please migrate to libata."
ewarn
@@ -378,20 +376,22 @@ pkg_postinst()
ewarn "http://www.gentoo.org/doc/en/initramfs-guide.xml"
fi
- ewarn
- ewarn "The udev-acl functionality has been removed from standalone udev."
- ewarn "If you are using standalone udev, consolekit handles this"
- ewarn "functionality."
+ if use acl; then
+ ewarn
+ ewarn "The udev-acl functionality has been moved."
+ ewarn "If you are not using systemd, this is handled by consolekit."
+ ewarn "Otherwise, you need to make sure that systemd is emerged with"
+ ewarn "the acl use flag active."
+ fi
if [[ -d ${ROOT}lib/udev ]]
then
ewarn
- ewarn "This version of udev moves the files that were installed in"
- ewarn "/lib/udev to /usr/lib/udev."
- ewarn "We include a backward compatibility patch for gentoo to"
- ewarn "allow the rules in /lib/udev/rules.d to be read. However,"
- ewarn "bugs should be filed against packages that are installing"
- ewarn "files in /lib/udev so they can be fixed."
+ ewarn "This version of udev moves the files which were installed in"
+ ewarn "/lib/udev to /usr/lib/udev. We include a backward compatibility"
+ ewarn "patch for gentoo to allow the rules in /lib/udev/rules.d to be"
+ ewarn "read; however, bugs should be filed against packages which are"
+ ewarn "installing things in /lib/udev so they can be fixed."
fi
ewarn
@@ -403,6 +403,10 @@ pkg_postinst()
ewarn "Upstream has removed the persistent-net and persistent-cd rules"
ewarn "generator. If you need persistent names for these devices,"
ewarn "place udev rules for them in ${ROOT}etc/udev/rules.d."
+ ewarn "Be aware that you cannot directly swap device names, so persistent"
+ ewarn "rules for network devices should be like the ones at the following"
+ ewarn "URL:"
+ ewarn "http://bugs.gentoo.org/show_bug.cgi?id=433746#C1"
preserve_old_lib_notify /$(get_libdir)/libudev.so.0