summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-09-09 12:58:21 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-09-09 12:58:21 +0000
commite654996fd65aab518a6028111838d97c3df8e654 (patch)
treec7b532119a2769f6e429840dfb351531e8ab2ea4 /sys-fs/squashfs-tools
parentVersion bump; removed 2.7.x ebuilds. (diff)
downloadhistorical-e654996fd65aab518a6028111838d97c3df8e654.tar.gz
historical-e654996fd65aab518a6028111838d97c3df8e654.tar.bz2
historical-e654996fd65aab518a6028111838d97c3df8e654.zip
Version bump and closing bug #99886.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog8
-rw-r--r--sys-fs/squashfs-tools/Manifest6
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2_p21
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-2.2_p2.ebuild39
4 files changed, 51 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index bca2933a9edb..482a73c6a25a 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.21 2005/07/22 13:24:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.22 2005/09/09 12:58:21 wolf31o2 Exp $
+
+*squashfs-tools-2.2_p2 (09 Sep 2005)
+
+ 09 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +squashfs-tools-2.2_p2.ebuild:
+ Version bump and closing bug #99886.
*squashfs-tools-2.2 (22 Jul 2005)
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
index ec94613cbd8b..38f623156f91 100644
--- a/sys-fs/squashfs-tools/Manifest
+++ b/sys-fs/squashfs-tools/Manifest
@@ -1,6 +1,8 @@
-MD5 47d9ca1c4f3762a068e793a6191a9899 ChangeLog 3805
-MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
+MD5 c6cf843ce967d6925448942a6a6d512f squashfs-tools-2.2_p2.ebuild 958
MD5 775b98e784ddd48e7168e2e4cce3cf12 squashfs-tools-2.1_p2-r1.ebuild 952
MD5 93577b9d72809b1fe859ab4502a23aa1 squashfs-tools-2.2.ebuild 956
+MD5 c5cdfdd70500b9a4db19ef2295999087 ChangeLog 3970
+MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
MD5 79b98e5d18ebd17486dca6802a1ac7d4 files/digest-squashfs-tools-2.1_p2-r1 66
MD5 9abe5a7ab20b24f552d43f654c9214a6 files/digest-squashfs-tools-2.2 63
+MD5 8e1ba2a524f27a8d5629ea4c5082d4cc files/digest-squashfs-tools-2.2_p2 65
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2_p2 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2_p2
new file mode 100644
index 000000000000..d29239117d8f
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2_p2
@@ -0,0 +1 @@
+MD5 86b917ad06378805a760433be1758d2b squashfs2.2r2.tar.gz 234873
diff --git a/sys-fs/squashfs-tools/squashfs-tools-2.2_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-2.2_p2.ebuild
new file mode 100644
index 000000000000..7820d92ba4b1
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-2.2_p2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-2.2_p2.ebuild,v 1.1 2005/09/09 12:58:21 wolf31o2 Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_p/r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES README-2.{0,1} README-AMD64 \
+ PERFORMANCE.README
+}