summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-07-22 13:24:16 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-07-22 13:24:16 +0000
commit5b1f0fcb38f7cce0d3d811e25f7121a819f90c5e (patch)
tree01c6449255cf927a700034ff0e5ab4cd3a68c978 /sys-fs/squashfs-tools
parentUpdate version. (diff)
downloadhistorical-5b1f0fcb38f7cce0d3d811e25f7121a819f90c5e.tar.gz
historical-5b1f0fcb38f7cce0d3d811e25f7121a819f90c5e.tar.bz2
historical-5b1f0fcb38f7cce0d3d811e25f7121a819f90c5e.zip
Version bumped to latest version.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog8
-rw-r--r--sys-fs/squashfs-tools/Manifest6
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-2.21
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-2.2.ebuild39
4 files changed, 51 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index 53850d7bda29..bca2933a9edb 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.20 2005/05/16 17:48:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.21 2005/07/22 13:24:16 wolf31o2 Exp $
+
+*squashfs-tools-2.2 (22 Jul 2005)
+
+ 22 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +squashfs-tools-2.2.ebuild:
+ Version bumped to latest version.
16 May 2005; Chris Gianelloni <wolf31o2@gentoo.org>
squashfs-tools-2.1_p2-r1.ebuild:
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
index cb3c8d260b60..ec94613cbd8b 100644
--- a/sys-fs/squashfs-tools/Manifest
+++ b/sys-fs/squashfs-tools/Manifest
@@ -1,4 +1,6 @@
-MD5 775b98e784ddd48e7168e2e4cce3cf12 squashfs-tools-2.1_p2-r1.ebuild 952
-MD5 08628fc64b3cd5f676953421ae0701c7 ChangeLog 3649
+MD5 47d9ca1c4f3762a068e793a6191a9899 ChangeLog 3805
MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
+MD5 775b98e784ddd48e7168e2e4cce3cf12 squashfs-tools-2.1_p2-r1.ebuild 952
+MD5 93577b9d72809b1fe859ab4502a23aa1 squashfs-tools-2.2.ebuild 956
MD5 79b98e5d18ebd17486dca6802a1ac7d4 files/digest-squashfs-tools-2.1_p2-r1 66
+MD5 9abe5a7ab20b24f552d43f654c9214a6 files/digest-squashfs-tools-2.2 63
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2
new file mode 100644
index 000000000000..b0fd3859f44b
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-2.2
@@ -0,0 +1 @@
+MD5 9537f1bfa3efd5df722f1a85cd424414 squashfs2.2.tar.gz 233078
diff --git a/sys-fs/squashfs-tools/squashfs-tools-2.2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-2.2.ebuild
new file mode 100644
index 000000000000..13888226fd72
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-2.2.ebuild,v 1.1 2005/07/22 13:24:16 wolf31o2 Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_p/-r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES README-2.{0,1} README-AMD64 \
+ PERFORMANCE.README
+}