summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2004-05-12 13:12:34 +0000
committerAlexander Gabert <pappy@gentoo.org>2004-05-12 13:12:34 +0000
commit60064d770a27d862ecf04bf1bf7a370e657a9a91 (patch)
treebb429cfc51998abfd9d67bc76db8332dbab2dd68 /sys-fs/dosfstools/dosfstools-2.10.ebuild
parentchanged hardened-gcc logic to filter-flags (diff)
downloadhistorical-60064d770a27d862ecf04bf1bf7a370e657a9a91.tar.gz
historical-60064d770a27d862ecf04bf1bf7a370e657a9a91.tar.bz2
historical-60064d770a27d862ecf04bf1bf7a370e657a9a91.zip
changed hardened-gcc logic to filter-flags
Diffstat (limited to 'sys-fs/dosfstools/dosfstools-2.10.ebuild')
-rw-r--r--sys-fs/dosfstools/dosfstools-2.10.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-fs/dosfstools/dosfstools-2.10.ebuild b/sys-fs/dosfstools/dosfstools-2.10.ebuild
index 655628e49e95..ac9f050b47bd 100644
--- a/sys-fs/dosfstools/dosfstools-2.10.ebuild
+++ b/sys-fs/dosfstools/dosfstools-2.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.10.ebuild,v 1.8 2004/03/25 00:02:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.10.ebuild,v 1.9 2004/05/12 13:12:34 pappy Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="dos filesystem tools"
SRC_URI="ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/${P}.src.tar.gz"
@@ -23,11 +23,14 @@ src_unpack() {
# Bug: 34785 hardened-gcc transparently adds -fPIC so we must filter
# that away because this package cant cope. (Nov 30 2003 -solar)
- has_version 'sys-devel/hardened-gcc' && \
- sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
+ # has_version 'sys-devel/hardened-gcc' && \
+ # sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
}
src_compile() {
+
+ filter-flags -fPIC
+
# this package does *not* play well with optimisations
# please dont change to: make OPTFLAGS="${CFLAGS}"
make || die