summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2004-12-11 17:17:07 +0000
committerDaniel Drake <dsd@gentoo.org>2004-12-11 17:17:07 +0000
commit47a21735b88af7001a5404b5ef0c83ee209827e1 (patch)
tree660960998acaa6b2e01783c5cb7575c9920e0881 /sys-fs/cloop
parentStable on alpha. (diff)
downloadhistorical-47a21735b88af7001a5404b5ef0c83ee209827e1.tar.gz
historical-47a21735b88af7001a5404b5ef0c83ee209827e1.tar.bz2
historical-47a21735b88af7001a5404b5ef0c83ee209827e1.zip
Fix 2.4 compilation
Diffstat (limited to 'sys-fs/cloop')
-rw-r--r--sys-fs/cloop/ChangeLog5
-rw-r--r--sys-fs/cloop/Manifest14
-rw-r--r--sys-fs/cloop/cloop-2.01.5.ebuild9
3 files changed, 14 insertions, 14 deletions
diff --git a/sys-fs/cloop/ChangeLog b/sys-fs/cloop/ChangeLog
index a0d8c078afe0..b3d7104e7ec1 100644
--- a/sys-fs/cloop/ChangeLog
+++ b/sys-fs/cloop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/cloop
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/ChangeLog,v 1.4 2004/11/24 16:23:51 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/ChangeLog,v 1.5 2004/12/11 17:17:07 dsd Exp $
+
+ 11 Dec 2004; Daniel Drake <dsd@gentoo.org> cloop-2.01.5.ebuild:
+ Fix 2.4 compilation
24 Nov 2004; Stefan Schweizer <genstef@gentoo.org>
+files/cloop.zlib-amd64.patch, cloop-2.01.5.ebuild:
diff --git a/sys-fs/cloop/Manifest b/sys-fs/cloop/Manifest
index 96c463d2da65..b5208814a1ab 100644
--- a/sys-fs/cloop/Manifest
+++ b/sys-fs/cloop/Manifest
@@ -1,11 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 a9c58ce17c978363b0aa5e2e6545c7ba cloop-0.68.ebuild 2110
-MD5 48fab355f7c8d27fa49a2afb3de0c15f cloop-2.01.5.ebuild 1963
+MD5 92cbdba7a8888eb362afae91b159eb32 cloop-2.01.5.ebuild 2202
MD5 f921e57967efb1fc6c2cb4ccb0dcbb92 cloop-2.00.ebuild 2027
MD5 7498bc7803ebc9010d29cecefc3079b6 cloop-1.0.ebuild 1832
-MD5 6d4148ed99a22710207735942d68c58d ChangeLog 2140
+MD5 7636ead76228a9c0e164d2bc204df35e ChangeLog 2224
MD5 4bb124b6d8e7842a97dd4b5fc87c545a cloop-1.02.ebuild 1938
MD5 2d8e24e9e409e35ee446ec8d59f23c8d metadata.xml 269
MD5 fddd6265f57fe660c663a7b5b673f7f7 files/kernel-2.6.8-fs_h-fix.patch 759
@@ -17,10 +14,3 @@ MD5 cc6063c4f68af1ae01cf6437c8a224b8 files/digest-cloop-2.00 63
MD5 4666ce65a6ce33f0a2c449fcec7e0488 files/cloop.fix.patch 2071
MD5 eba344b1fcf93c086a762d9f059adf84 files/digest-cloop-2.01.5 64
MD5 ab48f2b1094c297eaa04e42906bf652b files/kernel26_amd64.patch 2121
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBpLWfI1lqEGTUzyQRAl7IAKCM90hE1IKK0SO+4Rvgr6XkEE6dIACg0Un+
-3bXzJ2iV2Kk0WuuMAPlcvrc=
-=3EK4
------END PGP SIGNATURE-----
diff --git a/sys-fs/cloop/cloop-2.01.5.ebuild b/sys-fs/cloop/cloop-2.01.5.ebuild
index 0fc3d3004817..8a6cad73ea4e 100644
--- a/sys-fs/cloop/cloop-2.01.5.ebuild
+++ b/sys-fs/cloop/cloop-2.01.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.01.5.ebuild,v 1.2 2004/11/24 06:08:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.01.5.ebuild,v 1.3 2004/12/11 17:17:07 dsd Exp $
inherit kernel-mod eutils versionator
@@ -32,6 +32,13 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/cloop.fix.patch
epatch ${FILESDIR}/cloop.zlib-amd64.patch
+
+ # Debian uses conf.vars, everyone else uses .config
+ sed -i "s:conf.vars:.config:" Makefile
+
+ # Remove erroneous 2.4 include
+ kernel-mod_is_2_4_kernel && \
+ sed -i "s:#include <netinet/in.h>::" advancecomp-1.9_create_compressed_fs/advfs.cc
}
src_compile() {