summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-09 21:35:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-09 21:35:29 +0000
commit11e1374dfeefda811f21194ce90af89d118bd633 (patch)
tree20328f847b7138151e38164b19fd6bb99b2052a2 /sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild
parentVersion bump, based on work of Yuta SATOH in bug #476646 (diff)
downloadhistorical-11e1374dfeefda811f21194ce90af89d118bd633.tar.gz
historical-11e1374dfeefda811f21194ce90af89d118bd633.tar.bz2
historical-11e1374dfeefda811f21194ce90af89d118bd633.zip
Version bump, based on work of Yuta SATOH in bug #476646
Package-Manager: portage-2.2.0_alpha196/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild')
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild
new file mode 100644
index 000000000000..8c9e632e08d0
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc1.ebuild,v 1.1 2013/08/09 21:35:22 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic multilib
+
+DESCRIPTION="Contributed sources for FreeBSD."
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+fi
+LICENSE="BSD GPL-2+ libodialog"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ freebsd_src_unpack
+ else
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libodialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib/libodialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libodialog"
+ mkinstall LIBDIR="/usr/$(get_libdir)" || die "libodialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "sort install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "patch install failed"
+}