summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-16 03:38:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-16 03:38:50 +0000
commitebbf13abe5f14859c3f94c189031a9eb2c107292 (patch)
tree92bc2be899ada51aed0133b6da7b3f243654fe6a /sys-devel
parentStable on x86; bug #125343 (diff)
downloadhistorical-ebbf13abe5f14859c3f94c189031a9eb2c107292.tar.gz
historical-ebbf13abe5f14859c3f94c189031a9eb2c107292.tar.bz2
historical-ebbf13abe5f14859c3f94c189031a9eb2c107292.zip
add support for vax targets and packages in $PORTDIR_OVERLAY #126284
Package-Manager: portage-2.1_pre6-r3
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest12
-rwxr-xr-xsys-devel/crossdev/files/crossdev18
2 files changed, 18 insertions, 12 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 61ac76853d05..41faf79b8573 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -7,9 +7,9 @@ SHA256 b76775f693599c6389cacb7e83943c4b5077216e0dafa0666f44b425bbe7b744 ChangeLo
MD5 a261e324584f12c1a9d4a2b73d6d4954 crossdev-0.9.13.ebuild 648
RMD160 8b7005d0adefde6b0834410c0bdfab89180891b1 crossdev-0.9.13.ebuild 648
SHA256 46c07dcaeacb6e00634ec20be3ea119046dff62b706f59ac25a8d3ab64efa7b7 crossdev-0.9.13.ebuild 648
-MD5 a02c360b77267631c8e62b8cd8af1db5 files/crossdev 16190
-RMD160 36d8e0d14326bf24bdfb282e01ad351a5252a4f7 files/crossdev 16190
-SHA256 6760182db7bb1b3ac5962431fe9a25d15b277c38258e20b7239da07dba126f1c files/crossdev 16190
+MD5 449cae0f2467444376d8d398447b6ed2 files/crossdev 16358
+RMD160 7cd3e4fb03897433a7846c95f67248e25a7bd5f4 files/crossdev 16358
+SHA256 a8add713e41bd5628a32c82ca2f7bd4ebbef777c9a427f8e330d8a2e4cf6eb5b files/crossdev 16358
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-crossdev-0.9.13 0
RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-crossdev-0.9.13 0
SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-crossdev-0.9.13 0
@@ -19,7 +19,7 @@ SHA256 c11360fafdb92d96d343530a7f5869494a27c5cc1fec703094b1221632b6163f metadata
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
-iD8DBQFEF1mV2+ySkm8kpY0RAtQfAKDD2u7Kheaxnb/k3BF6HW/LApsi6QCgvFGw
-KClrxzd6+RDmV1eW42doBE0=
-=gxZ5
+iD8DBQFEGN3V2+ySkm8kpY0RAnb2AJkBeLWVxLSRiFQYkc5cTaJL/fA6qgCgqI4l
+faQrQBKRxP/C0dHsy09eCKM=
+=7vsQ
-----END PGP SIGNATURE-----
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 8dd6e5406877..1dd2a3b032e1 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.53 2006/03/15 00:00:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.54 2006/03/16 03:38:50 vapier Exp $
cd /
@@ -111,8 +111,7 @@ parse_target() {
TARCH=${HARCH};
BPKG="binutils-bfin";
GPKG="gcc-bfin";
- LPKG="uclibc";
- STAGE=${STAGE_C_KERNEL};;
+ LPKG="uclibc";;
cris*)
TARCH=${HARCH};
@@ -126,8 +125,10 @@ parse_target() {
TARCH=${HARCH};
BPKG="binutils-nios2";
GPKG="gcc-nios2";
- LPKG="uclibc";
- STAGE=${STAGE_C_KERNEL};;
+ LPKG="uclibc";;
+
+ vax*) TARCH=${HARCH};
+ LPKG="uclibc";;
ps2*) einfo "The ps2 target is really an alias for the ee/iop/dvp targets"
${CROSSDEV} -t ee || exit 1
@@ -449,7 +450,12 @@ set_links() {
local cat=$1 pkg=$2
[[ -e ${PORTDIR_OVERLAY}/cross-${CTARGET}/${pkg} ]] \
&& rm -f "${PORTDIR_OVERLAY}"/cross-${CTARGET}/${pkg}
- ln -s "${PORTDIR}"/${cat}/${pkg} "${PORTDIR_OVERLAY}"/cross-${CTARGET}/${pkg}
+ local srcdir=${PORTDIR}
+ if [[ -e ${PORTDIR_OVERLAY}/${cat}/${pkg} ]] ; then
+ einfo "Using ${cat}/${pkg} from ${PORTDIR_OVERLAY} instead of ${PORTDIR}"
+ srcdir=${PORTDIR_OVERLAY}
+ fi
+ ln -s "${srcdir}"/${cat}/${pkg} "${PORTDIR_OVERLAY}"/cross-${CTARGET}/${pkg}
}
set_portage() {
local cat=$1 pkg=$2 ver=$3