summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-25 01:39:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-25 01:39:33 +0000
commite734e27810a3b0b92e58b751de595a03cfbcad0a (patch)
tree143cd98f15ca6dbc8bccadfc3c0de08a99ee537a /sys-devel
parentFirst round of Tiger package.provided updates. (diff)
downloadhistorical-e734e27810a3b0b92e58b751de595a03cfbcad0a.tar.gz
historical-e734e27810a3b0b92e58b751de595a03cfbcad0a.tar.bz2
historical-e734e27810a3b0b92e58b751de595a03cfbcad0a.zip
stub files in case the toolchain doesnt really support htb/ssp
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/Manifest8
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch59
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch45
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch31
-rw-r--r--sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch43
5 files changed, 184 insertions, 2 deletions
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index 4eb9ea49af5c..68615ff9b55c 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -5,7 +5,7 @@ MD5 37f3db1694d592dc3a3db07507390b76 gcc-3.1.1-r2.ebuild 9270
MD5 3196c90905902891b12b4d08372c0eb5 gcc-2.95.3-r9.ebuild 7524
MD5 37ae28535bb42708bc729e53512ad369 gcc-3.3.2-r5.ebuild 21306
MD5 3e3bc1c3e3953428824c0fd3f206c48b gcc-3.3.2-r7.ebuild 21757
-MD5 d4951444d2cee14710960f2319df0ff5 gcc-3.3.6.ebuild 2850
+MD5 cfaa9a52d9630bb289bd301d96945302 gcc-3.3.6.ebuild 2850
MD5 db8f65e7648911fb9d8484c13e77676e gcc-3.3.2.ebuild 16816
MD5 2db26494ddce8e007dbfb8b7eb1bc1f5 gcc-3.3.5-r1.ebuild 3733
MD5 240c9f26c319c0f305822d43d6daee5e gcc-3.4.3.20050110-r2.ebuild 5188
@@ -21,7 +21,7 @@ MD5 71b180bed94dca00dddf253f7bd6508f gcc-3.2.3-r4.ebuild 19841
MD5 b8b548680eb8d38969c65b0be505a095 gcc-4.0.0.ebuild 1709
MD5 f7e7042c2ddf66e344b30cbc66ebaf73 files/cc 24
MD5 80d122265d3062847a4a1b161abe1d26 files/cpp 24
-MD5 5239bde880ec2b4b0fc23fc477f7613f files/digest-gcc-3.3.6 384
+MD5 18b9535a343359e167a98b9dad4596e4 files/digest-gcc-3.3.6 384
MD5 a570da9000df56c70620ec2e36e864a3 files/digest-gcc-2.95.3-r8 137
MD5 0d683280daf95e6bb9712549352a200c files/digest-gcc-3.1.1-r2 140
MD5 40e6872c09149a81973f01a78c80bbb7 files/digest-gcc-3.2.3-r4 279
@@ -89,6 +89,10 @@ MD5 d9ae122db2768f8e504dfef256d4991f files/3.3.2/gcc332-gentoo-branding.patch 87
MD5 9e7ed6184a1cdcb69db29f1de26c2d18 files/3.3.2/gcc332-altivec-fix.patch 1607
MD5 f8c48b2e721c21d83582f5884bfb79c7 files/awk/fixlafiles.awk 7830
MD5 c672adb59a1f452475ab0a864b9d1bd1 files/awk/scanforssp.awk 5830
+MD5 57bc3a63ac4125a3dd90864462d57053 files/stubs/gcc-3.4-htb-stub.patch 702
+MD5 cb27bc36a5b9a1175a5f3bdf38647814 files/stubs/gcc-3.3-ssp-stub.patch 1735
+MD5 00f16b0da434ce80fd4dbd6e88ba5fbd files/stubs/gcc-3.4-ssp-stub.patch 1125
+MD5 0f8035bc5ae6126fd9380ba9dcdcc271 files/stubs/gcc-3.3-htb-stub.patch 2195
MD5 cd87c02e4896f47bf6029eef0dc29468 files/3.3.3/gcc333-gentoo-branding.patch 874
MD5 0e8d94bbc14fbb3fbad1df4f404b39ef files/3.3.3/gcc333-ssp-3.3_7-fixup.patch 2616
MD5 4b249bff27ab6328436e6289ac9f9cfc files/3.3.3/gcc333_pre20040215-gentoo-branding.patch 839
diff --git a/sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch
new file mode 100644
index 000000000000..f6d81040c58c
--- /dev/null
+++ b/sys-devel/gcc/files/stubs/gcc-3.3-htb-stub.patch
@@ -0,0 +1,59 @@
+--- gcc-3.3.6/gcc/c-opts.c
++++ gcc-3.3.6/gcc/c-opts.c
+@@ -193,6 +193,8 @@ static void sanitize_cpp_opts PARAMS ((v
+ OPT("fall-virtual", CL_CXX, OPT_fall_virtual) \
+ OPT("falt-external-templates",CL_CXX, OPT_falt_external_templates) \
+ OPT("fasm", CL_ALL, OPT_fasm) \
++ OPT("fbc-strings-only", CL_ALL, OPT_fbc_strings_only) \
++ OPT("fbounds-checking", CL_ALL, OPT_fbounds_checking) \
+ OPT("fbuiltin", CL_ALL, OPT_fbuiltin) \
+ OPT("fbuiltin-", CL_ALL | CL_JOINED, OPT_fbuiltin_) \
+ OPT("fcheck-new", CL_CXX, OPT_fcheck_new) \
+@@ -1037,6 +1039,11 @@ c_common_decode_option (argc, argv)
+ flag_no_asm = !on;
+ break;
+
++ case OPT_fbounds_checking:
++ case OPT_fbc_strings_only:
++ warning ("htb stub: bounds checking is not supported");
++ break;
++
+ case OPT_fbuiltin:
+ flag_no_builtin = !on;
+ break;
+--- gcc-3.3.6/gcc/cp/lang-options.h
++++ gcc-3.3.6/gcc/cp/lang-options.h
+@@ -32,6 +32,8 @@ DEFINE_LANG_NAME ("C++")
+ { "-fno-alt-external-templates", "" },
+ { "-fansi-overloading", "" },
+ { "-fno-ansi-overloading", "" },
++ { "-fbounds-checking", "" },
++ { "-fno-bounds-checking", "" },
+ { "-fcheck-new",
+ N_("Check the return value of new") },
+ { "-fno-check-new", "" },
+@@ -117,6 +119,9 @@ DEFINE_LANG_NAME ("C++")
+ { "-fxref",
+ N_("Emit cross referencing information") },
+ { "-fno-xref", "" },
++ { "-fbounds-checking",
++ N_("Generate array and pointer bounds checking code") },
++ { "-fno-bounds-checking", "" },
+
+ { "-Wreturn-type",
+ N_("Warn about inconsistent return types") },
+--- gcc-3.3.6/gcc/toplev.c
++++ gcc-3.3.6/gcc/toplev.c
+@@ -1249,6 +1267,12 @@ documented_lang_options[] =
+ { "-fshort-wchar",
+ N_("Override the underlying type for wchar_t to `unsigned short'") },
+ { "-fno-short-wchar", "" },
++ { "-fbounds-checking",
++ N_("Generate array and pointer bounds checking code") },
++ { "-fno-bounds-checking", "" },
++ { "-fbc-strings-only",
++ N_("Restrict bounds checking to strings only") },
++ { "-fno-bc-strings-only", "" },
+
+ { "-Wall",
+ N_("Enable most warning messages") },
diff --git a/sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch
new file mode 100644
index 000000000000..ed996e7df428
--- /dev/null
+++ b/sys-devel/gcc/files/stubs/gcc-3.3-ssp-stub.patch
@@ -0,0 +1,45 @@
+--- gcc-3.3.6/gcc/toplev.c
++++ gcc-3.3.6/gcc/toplev.c
+@@ -904,6 +904,10 @@ int align_functions_log;
+ minimum function alignment. Zero means no alignment is forced. */
+ int force_align_functions_log;
+
++int flag_propolice_protection = 0;
++int flag_stack_protection = 0;
++int warn_stack_protector = 0;
++
+ /* Table of supported debugging formats. */
+ static const struct
+ {
+@@ -1188,6 +1197,10 @@ static const lang_independent_options f_
+ N_("Trap for signed overflow in addition / subtraction / multiplication") },
+ { "new-ra", &flag_new_regalloc, 1,
+ N_("Use graph coloring register allocation.") },
++ {"stack-protector", &flag_propolice_protection, 1,
++ N_("Enables stack protection") },
++ {"stack-protector-all", &flag_stack_protection, 1,
++ N_("Enables stack protection of every function") } ,
+ };
+
+ /* Table of language-specific options. */
+@@ -1547,7 +1560,9 @@ static const lang_independent_options W_
+ {"missing-noreturn", &warn_missing_noreturn, 1,
+ N_("Warn about functions which might be candidates for attribute noreturn") },
+ {"strict-aliasing", &warn_strict_aliasing, 1,
+- N_ ("Warn about code which might break the strict aliasing rules") }
++ N_ ("Warn about code which might break the strict aliasing rules") },
++ {"stack-protector", &warn_stack_protector, 1,
++ N_("Warn when disabling stack protector for some reason")}
+ };
+
+ void
+@@ -5230,6 +5247,9 @@ process_options ()
+ /* The presence of IEEE signaling NaNs, implies all math can trap. */
+ if (flag_signaling_nans)
+ flag_trapping_math = 1;
++
++ if (flag_stack_protection || flag_propolice_protection)
++ warning ("ssp stub: stack protector is not supported");
+ }
+
+ /* Initialize the compiler back end. */
diff --git a/sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch
new file mode 100644
index 000000000000..6b6d66338945
--- /dev/null
+++ b/sys-devel/gcc/files/stubs/gcc-3.4-htb-stub.patch
@@ -0,0 +1,31 @@
+--- gcc-3.4.4/gcc/c.opt
++++ gcc-3.4.4/gcc/c.opt
+@@ -426,6 +426,14 @@ fasm
+ C ObjC C++ ObjC++
+ Recognize the \"asm\" keyword
+
++fbounds-checking
++C
++Generate code to check bounds before indexing arrays
++
++fbc-strings-only
++C
++Restrict bounds checking to strings only
++
+ fbuiltin
+ C ObjC C++ ObjC++
+ Recognize built-in functions
+--- gcc-3.4.4/gcc/c-opts.c
++++ gcc-3.4.4/gcc/c-opts.c
+@@ -708,6 +708,11 @@ c_common_handle_option (size_t scode, co
+ flag_no_asm = !value;
+ break;
+
++ case OPT_fbounds_checking:
++ case OPT_fbc_strings_only:
++ warning ("htb stub: bounds checking is not supported");
++ break;
++
+ case OPT_fbuiltin:
+ flag_no_builtin = !value;
+ break;
diff --git a/sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch b/sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch
new file mode 100644
index 000000000000..74353d824c51
--- /dev/null
+++ b/sys-devel/gcc/files/stubs/gcc-3.4-ssp-stub.patch
@@ -0,0 +1,43 @@
+--- gcc-3.4.3/gcc/common.opt
++++ gcc-3.4.3/gcc/common.opt
+@@ -152,6 +152,10 @@ Wunused-variable
+ Common
+ Warn when a variable is unused
+
++Wstack-protector
++Common
++Warn when not issuing stack smashing protection for some reason
++
+ aux-info
+ Common Separate
+ -aux-info <file> Emit declaration information into <file>
+@@ -743,6 +747,14 @@ fzero-initialized-in-bss
+ Common
+ Put zero initialized data in the bss section
+
++fstack-protector
++Common
++Enables stack protection
++
++fstack-protector-all
++Common
++Enables stack protection of every function
++
+ g
+ Common JoinedOrMissing
+ Generate debug information in default format
+--- gcc-3.4.3.orig/gcc/opts.c 2005-01-10 20:01:46.000000000 -0800
++++ gcc-3.4.3/gcc/opts.c 2005-01-11 00:04:13.000000000 -0800
+@@ -804,6 +807,12 @@ common_handle_option (size_t scode, cons
+ warn_unused_variable = value;
+ break;
+
++ case OPT_fstack_protector:
++ case OPT_fstack_protector_all:
++ case OPT_Wstack_protector:
++ warning ("ssp stub: stack protector is not supported");
++ break;
++
+ case OPT_aux_info:
+ case OPT_aux_info_:
+ aux_info_file_name = arg;