summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-05-27 23:07:41 +0000
committerZack Welch <zwelch@gentoo.org>2003-05-27 23:07:41 +0000
commitd3630465a60220dce5c90bdbf81189b9e99e6952 (patch)
treeaeb5e1fea2f2b139bc37d4977a366b211c12504c /sys-devel
parentnew version; fixes to init script as proposed by agriffis (diff)
downloadhistorical-d3630465a60220dce5c90bdbf81189b9e99e6952.tar.gz
historical-d3630465a60220dce5c90bdbf81189b9e99e6952.tar.bz2
historical-d3630465a60220dce5c90bdbf81189b9e99e6952.zip
new version; fixes to init script as proposed by agriffis
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.5.ebuild95
-rw-r--r--sys-devel/distcc/files/1.2/init13
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.51
4 files changed, 100 insertions, 13 deletions
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 0cbeff82ff5d..d381979f17c1 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,10 +1,10 @@
-MD5 353c2990fe50f7d7a4f21d4d9dc9c79f ChangeLog 7651
+MD5 39c61763d090239991c94e6f5a3a6b7c ChangeLog 396
MD5 960b9f9b17b8f9dd99094d162362dd1b distcc-2.0.1-r1.ebuild 2892
MD5 da890f4d3d7a6c3cb65ad47f80feff6a distcc-2.0.1.ebuild 2895
MD5 8df905f30d3f4bce8c31534396b66ec8 distcc-2.3.ebuild 2691
MD5 c242a8c0ff4035a2c6a3ee0545691aed distcc-2.4.ebuild 2702
MD5 3bc5a82158ff39298b4b80134999ddde distcc-2.4.2.ebuild 2703
-MD5 3bc5a82158ff39298b4b80134999ddde distcc-2.5.ebuild 2703
+MD5 c958bfeb956960d4b15ebab2df7a6d86 distcc-2.5.ebuild 2702
MD5 372827ac4fc6b9dae1d585934369ce8e distcc-1.2.3-r3.ebuild 2882
MD5 9a3a39b4f229559e6a855d777c6fe807 files/digest-distcc-2.0.1-r1 65
MD5 8aa55227d128b8ff22a8caf5d47db89c files/digest-distcc-2.3 63
diff --git a/sys-devel/distcc/distcc-2.5.ebuild b/sys-devel/distcc/distcc-2.5.ebuild
new file mode 100644
index 000000000000..7fc2d303df71
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.5.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.5.ebuild,v 1.1 2003/05/27 23:07:38 zwelch Exp $
+
+inherit eutils
+
+IUSE=""
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+OPV="1.2"
+LPV="2.3"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-libs/popt"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${LPV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${OPV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${OPV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+
+ einfo "To use distcc with **non-Portage** C compiling, add"
+ einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
+ einfo "combining this with ccache, put the distcc dir AFTER ccache."
+ einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
+ einfo "distcc into the FEATURES setting in make.conf (and define"
+ einfo "DISTCC_HOSTS as well). Do NOT set CC=distcc or similar."
+ ewarn "See http://cvs.gentoo.org/~zwelch/distcc.html for information."
+}
+
+#pkg_prerm() {
+# # ztw - not sure if this is the right place
+# distcc-config --remove-links "${CHOST}"
+# distcc-config --remove-links
+#}
+
diff --git a/sys-devel/distcc/files/1.2/init b/sys-devel/distcc/files/1.2/init
index 98408aec5278..c183d62648ab 100644
--- a/sys-devel/distcc/files/1.2/init
+++ b/sys-devel/distcc/files/1.2/init
@@ -1,8 +1,5 @@
#!/sbin/runscript
-# get our configuration options
-source /etc/conf.d/distccd
-
depend() {
need net
}
@@ -15,19 +12,13 @@ start() {
--startas ${DISTCCD_EXEC} \
-c distcc --pidfile ${DISTCCD_PIDFILE} \
-- --pid-file ${DISTCCD_PIDFILE} ${DISTCCD_OPTS}
- eend $? "Failed to Start distccd"
+ eend $?
}
stop() {
ebegin "Stopping distccd"
start-stop-daemon --stop --quiet --pidfile "${DISTCCD_PIDFILE}"
rm -f "${DISTCCD_PIDFILE}"
- eend $? "Failed to Stop distccd"
+ eend $?
}
-restart() {
- ebegin "Restarting distccd"
- svc_stop
- svc_start
- eend $? "Failed to Restart distccd"
-}
diff --git a/sys-devel/distcc/files/digest-distcc-2.5 b/sys-devel/distcc/files/digest-distcc-2.5
new file mode 100644
index 000000000000..b14915b69443
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.5
@@ -0,0 +1 @@
+MD5 b0b6a34fa5a30bfa7f6853f477f7772f distcc-2.5.tar.bz2 220088