summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-22 02:56:38 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-22 02:56:38 +0000
commita536e55e59abe8d5dee93c47d48337a5faa4f36f (patch)
tree726304d4d1ae0d660f843005b952de650ad45160 /sys-devel
parentadd gcc-4 patch #86128 by Kristiaan Lenaerts (diff)
downloadhistorical-a536e55e59abe8d5dee93c47d48337a5faa4f36f.tar.gz
historical-a536e55e59abe8d5dee93c47d48337a5faa4f36f.tar.bz2
historical-a536e55e59abe8d5dee93c47d48337a5faa4f36f.zip
revert funky objc/gcj logic
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r12
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r1 b/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r1
index 1e76606d0319..d3bc41a04ebf 100644
--- a/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r1
+++ b/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r1
@@ -3,6 +3,6 @@ MD5 a158a57134253df324270f99e5b4a612 gcc-3.3.5-branch-update-20050130.patch.bz2
MD5 407883749eddbe6baae77f722c6e77d7 protector-3.3.5.20050130-1.tar.gz 24324
MD5 3c9f7b2bd066afe2888289595ac07104 gcc-3.3.5-uclibc-patches-1.0.tar.bz2 27532
MD5 aa0868ecce2185884c618de9a15eb40d gcc-3.3.5-manpages.tar.bz2 214965
-MD5 8d439bcf30bcba960c1059666e255240 gcc-3.3.5-patches-1.3.tar.bz2 42611
+MD5 2caecf5d5339bf70fb20b594d7f6d490 gcc-3.3.5-patches-1.4.tar.bz2 41936
MD5 9ffa098b60ba4e6eadcbbe50900fa295 gcc-3.3.5-piepatches-v8.7.7.1.tar.bz2 25970
MD5 f75ad40c0340ff23aba1dd4961285516 bounds-checking-gcc-3.3.5-1.00-r2.patch.bz2 827126
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
index 4c119c932866..853d154d7149 100644
--- a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.1 2005/03/19 00:46:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.2 2005/03/22 02:56:38 vapier Exp $
MAN_VER="3.3.5"
-PATCH_VER="1.3"
+PATCH_VER="1.4"
UCLIBC_VER="1.0"
PIE_VER="8.7.7.1"
PIE_CORE="gcc-3.3.5-piepatches-v${PIE_VER}.tar.bz2"
@@ -86,8 +86,8 @@ src_unpack() {
# Anything useful and objc will require libffi. Seriously. Lets just force
# libffi to install with USE="objc", even though it normally only installs
# if you attempt to build gcj.
- if ! ( ! use build && use objc && ! use gcj ) ; then
- GENTOO_PATCH_EXCLUDE="42*"
+ if use !build && use objc && ! use gcj ; then
+ epatch ${FILESDIR}/3.3.4/libffi-without-libgcj.patch
#epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
fi
}