summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-15 02:00:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-15 02:00:28 +0000
commit781e31a6c8a02e01746107f60de7d853b92a9ed4 (patch)
tree1a191e52282868dc729f95c491d60d2b3350eac9 /sys-devel
parentppc/uclibc (diff)
downloadhistorical-781e31a6c8a02e01746107f60de7d853b92a9ed4.tar.gz
historical-781e31a6c8a02e01746107f60de7d853b92a9ed4.tar.bz2
historical-781e31a6c8a02e01746107f60de7d853b92a9ed4.zip
create yacc symlink LIKE MAGIC #49331
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/Manifest10
-rw-r--r--sys-devel/bison/bison-1.875.ebuild24
3 files changed, 22 insertions, 18 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index ba7852f4e813..5fbc247cf1ae 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.31 2004/07/19 15:53:22 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.32 2004/10/15 02:00:28 vapier Exp $
+
+ 14 Oct 2004; Mike Frysinger <vapier@gentoo.org> bison-1.875.ebuild:
+ Dont install bison as yacc, but if yacc doesnt exist, create a symlink
+ #49331 by Bruno Redondi.
19 Jul 2004; <solar@gentoo.org> bison-1.875.ebuild:
updated bison to use gnuconfig.eclass. Needed for uclibc and maybe others.
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index efd8aff1c898..82e881390a2b 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -1,11 +1,11 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 92d7a109a6b9a45e321d99ad90dcae08 ChangeLog 4678
+MD5 8a80beaac760e397aed8da0bafb6ff80 ChangeLog 4850
MD5 35fee9889b6d304bfce347a2ad8a76dd bison-1.34-r1.ebuild 1123
MD5 06ab2a40b3da792bb74f57bd39ce2420 bison-1.35.ebuild 1225
MD5 5b8d6572f8235d7ce55b48bf732412d0 bison-1.75.ebuild 1072
-MD5 b517f79486dbb6e35dc076a10924bd0a bison-1.875.ebuild 1820
+MD5 0e880f3131fefee5c51c3a13d1f8a468 bison-1.875.ebuild 1865
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 61b224a9eaf1ae7f77c2d1456d8fda87 files/bison-1.32-extfix.patch 1170
MD5 644a4912da3e5107f509022f173ec146 files/bison-1.875-gccerror.patch 1538
@@ -16,7 +16,7 @@ MD5 4a875793f3bd808692002c152e5e26c4 files/digest-bison-1.875 64
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBVSHGHTu7gpaalycRAnFPAJ9ofhEcI7WoK25ytIudXhMpJY5BOQCgh/7G
-d3M2Bq0u1qRTk1HF4L4iNBU=
-=gba+
+iD8DBQFBby9EHTu7gpaalycRAuImAKDZzuRYbGzzhUc6LQealVgzVH31mACcDJ0R
+fuCfX6pS1Phmy6oxfhUc07Q=
+=mAYw
-----END PGP SIGNATURE-----
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index ab2a49d4b831..e29aa8d31256 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.24 2004/09/25 07:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.25 2004/10/15 02:00:28 vapier Exp $
inherit gcc flag-o-matic eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE="nls static uclibc"
DEPEND="sys-devel/m4
@@ -41,13 +41,9 @@ src_compile() {
replace-cpu-flags k6 k6-1 k6-2 i586
fi
- econf `use_enable nls` || die
-
- if use static; then
- emake LDFLAGS="-static" || die
- else
- emake || die
- fi
+ econf $(use_enable nls) || die
+ use static && append-ldflags -static
+ emake || die
}
src_install() {
@@ -58,9 +54,7 @@ src_install() {
install || die
# This one is installed by dev-util/yacc
- if ! use uclibc; then
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
- fi
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
# We do not need this.
rm -f ${D}/usr/lib/liby.a
@@ -69,3 +63,9 @@ src_install() {
docinto txt
dodoc doc/FAQ
}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}/usr/bin/yacc" ] ; then
+ ln -s yacc.bison /usr/bin/yacc
+ fi
+}