summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-10 20:29:31 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-10 20:29:31 +0000
commit67f1a88d18cc0f9da97ede2b2c7e611d06695d25 (patch)
tree564288dd049f052d8c5c8e49b3bb39ed5497a172 /sys-devel
parentClosing bug #3416. (diff)
downloadhistorical-67f1a88d18cc0f9da97ede2b2c7e611d06695d25.tar.gz
historical-67f1a88d18cc0f9da97ede2b2c7e611d06695d25.tar.bz2
historical-67f1a88d18cc0f9da97ede2b2c7e611d06695d25.zip
just small updates that should not really make any difference
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.0.4-r6.ebuild8
-rw-r--r--sys-devel/gcc/gcc-3.1-r6.ebuild10
2 files changed, 10 insertions, 8 deletions
diff --git a/sys-devel/gcc/gcc-3.0.4-r6.ebuild b/sys-devel/gcc/gcc-3.0.4-r6.ebuild
index 537d288d9d2d..518229899fd1 100644
--- a/sys-devel/gcc/gcc-3.0.4-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.0.4-r6.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Grant Goodyear <g2boojum@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.0.4-r6.ebuild,v 1.1 2002/05/03 00:54:58 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.0.4-r6.ebuild,v 1.2 2002/06/10 20:29:31 azarah Exp $
# NOTE TO MAINTAINER: Info pages get nuked for multiple version installs.
# Ill fix it later if i get a chance.
+inherit libtool
+
TV=4.0
GCC_SUFFIX=-3.0
LOC=/usr
@@ -31,7 +33,7 @@ build_multiple() {
profile="`readlink /etc/make.profile`"
if [ -z "`use build`" ] && \
[ -z "`use bootstrap`" ] && \
- [ "`gcc --version | cut -f1 -d.`" -ne 3 ] && \
+ [ "`gcc -dumpversion | cut -d. -f1,2`" != "`echo ${PV} | cut -d. -f1,2`" ] && \
[ "${profile/gcc3}" = "${profile}" ] && \
[ "${GCCBUILD}" != "default" ]
then
@@ -66,7 +68,7 @@ src_unpack() {
fi
#fixup libtool to correctly generate .la files with portage
- patch <${FILESDIR}/libtool-1.4.1-portage.patch-v3 || die
+ elibtoolize
}
src_compile() {
diff --git a/sys-devel/gcc/gcc-3.1-r6.ebuild b/sys-devel/gcc/gcc-3.1-r6.ebuild
index 947466e9e0ff..fe7cbcfcdba6 100644
--- a/sys-devel/gcc/gcc-3.1-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.1-r6.ebuild
@@ -10,6 +10,8 @@
# in src_install() ... Ill implement auto-version detection
# later on.
+inherit libtool
+
GCC_SUFFIX=-3.1
LOC=/usr
# dont install in /usr/include/g++-v3/, as it will nuke gcc-3.0.x installs
@@ -59,12 +61,10 @@ FAKE_ROOT=""
src_unpack() {
unpack ${P}.tar.bz2
- #now we integrate texinfo-${TV} into gcc. It comes with texinfo-3.12.
cd ${S}
- #fixes the build system to properly do the transformation
- #of the binaries (thanks to Mandrake)
- #fixup libtool to correctly generate .la files with portage
- patch <${FILESDIR}/libtool-1.4.1-portage.patch-v3 || die
+ # Fixup libtool to correctly generate .la files with portage
+ # Only apply the portage patch, and only to ltmain.sh in ${S}/
+ elibtoolize --portage --shallow
# Red Hat patches
for x in gcc31-boehm-gc-libs.patch.bz2 \