summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-05 04:20:55 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-05 04:20:55 +0000
commit405916a8c46cf7bbf955f2f04e06f696a320aa8e (patch)
tree2224bcb5ab290e4fd6cbafbf328ea4558513d822 /sys-devel
parentPhoenix down on 3.2-r2 to fix clean up mistake. :( (diff)
downloadhistorical-405916a8c46cf7bbf955f2f04e06f696a320aa8e.tar.gz
historical-405916a8c46cf7bbf955f2f04e06f696a320aa8e.tar.bz2
historical-405916a8c46cf7bbf955f2f04e06f696a320aa8e.zip
Don't assume that . and .. are the first two entries returned by readdir. Thanks to Bob Miller in bug 45998 for the patch
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/pmake/ChangeLog9
-rw-r--r--sys-devel/pmake/Manifest7
-rw-r--r--sys-devel/pmake/files/digest-pmake-1.45-r41
-rw-r--r--sys-devel/pmake/files/skipdots.patch22
-rw-r--r--sys-devel/pmake/pmake-1.45-r4.ebuild63
5 files changed, 99 insertions, 3 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
index 23d3c2ff4afb..39d854352f05 100644
--- a/sys-devel/pmake/ChangeLog
+++ b/sys-devel/pmake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/pmake
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.9 2004/02/26 05:48:39 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.10 2004/04/05 04:20:55 agriffis Exp $
+
+*pmake-1.45-r4 (05 Apr 2004)
+
+ 05 Apr 2004; Aron Griffis <agriffis@gentoo.org> pmake-1.45-r4.ebuild,
+ files/skipdots.patch:
+ Don't assume that . and .. are the first two entries returned by readdir.
+ Thanks to Bob Miller in bug 45998 for the patch
25 Feb 2004; Jason Wever <weeve@gentoo.org> pmake-1.45-r3.ebuild:
Added ~sparc keyword.
diff --git a/sys-devel/pmake/Manifest b/sys-devel/pmake/Manifest
index 9093b8ce2480..2e9f25289573 100644
--- a/sys-devel/pmake/Manifest
+++ b/sys-devel/pmake/Manifest
@@ -1,8 +1,11 @@
-MD5 afb9e2f2494c0d283a52e5237a74954c ChangeLog 1405
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 aba4db2d4e3ea2ac8e952cbbb31a6c79 ChangeLog 1662
MD5 619d0976672df7e89310bd147ea2a106 pmake-1.45-r2.ebuild 1669
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 b2b540ae16ba1c5532b43fe919d74126 pmake-1.45-r3.ebuild 1543
+MD5 bf08f798e83439e10119afb1c3ac10c7 pmake-1.45-r4.ebuild 1752
MD5 56b250e5c99455640556fcb776b9bd7e files/01_all_groffpatch.patch 485
MD5 1095ca9c07bda375bf9674fe20d79ba6 files/02_all_mktemp.patch 406
MD5 aa2eb71443dc4352bdf910fcbaf9f05e files/digest-pmake-1.45-r2 65
+MD5 456fc1935fead6cfc1235eddf6259847 files/skipdots.patch 677
MD5 aa2eb71443dc4352bdf910fcbaf9f05e files/digest-pmake-1.45-r3 65
+MD5 aa2eb71443dc4352bdf910fcbaf9f05e files/digest-pmake-1.45-r4 65
diff --git a/sys-devel/pmake/files/digest-pmake-1.45-r4 b/sys-devel/pmake/files/digest-pmake-1.45-r4
new file mode 100644
index 000000000000..110fde3e22d0
--- /dev/null
+++ b/sys-devel/pmake/files/digest-pmake-1.45-r4
@@ -0,0 +1 @@
+MD5 c0f21ad413abbb2fc76ec0d4d426578f pmake_1.45-11.tar.gz 252673
diff --git a/sys-devel/pmake/files/skipdots.patch b/sys-devel/pmake/files/skipdots.patch
new file mode 100644
index 000000000000..0bf81a9eeb7e
--- /dev/null
+++ b/sys-devel/pmake/files/skipdots.patch
@@ -0,0 +1,22 @@
+--- pmake-1.45.orig/dir.c 1997-09-28 04:46:39.000000000 -0700
++++ pmake-1.45/dir.c 2004-03-28 07:03:27.000000000 -0800
+@@ -1170,13 +1170,13 @@
+ p->refCount = 1;
+ Hash_InitTable (&p->files, -1);
+
+- /*
+- * Skip the first two entries -- these will *always* be . and ..
+- */
+- (void)readdir(d);
+- (void)readdir(d);
+-
+ while ((dp = readdir (d)) != (struct dirent *) NULL) {
++ /*
++ * Skip "." and ".."
++ */
++ if (!strcmp(dp->d_name, ".") || !strcmp(dp->d_name, "..")) {
++ continue;
++ }
+ #if defined(sun) && defined(d_ino) /* d_ino is a sunos4 #define for d_fileno */
+ /*
+ * The sun directory library doesn't check for a 0 inode
diff --git a/sys-devel/pmake/pmake-1.45-r4.ebuild b/sys-devel/pmake/pmake-1.45-r4.ebuild
new file mode 100644
index 000000000000..af55d1cde496
--- /dev/null
+++ b/sys-devel/pmake/pmake-1.45-r4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.45-r4.ebuild,v 1.1 2004/04/05 04:20:55 agriffis Exp $
+
+inherit eutils
+EPATCH_SOURCE="${FILESDIR}"
+EPATCH_SUFFIX="patch"
+
+DESCRIPTION="BSD build tool to create programs in parallel"
+HOMEPAGE="http://www.netbsd.org/"
+SRC_URI="mirror://gentoo/${PN}_${PV}-11.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~ppc alpha ia64 amd64 ~sparc"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die
+
+ # We do not want all patches in ${FILESDIR}, as 01_all_groffpatch.patch is
+ # not longer valid for this version.
+ epatch ${FILESDIR}/02_all_mktemp.patch
+
+ # pmake makes the assumption that . and .. are the first two
+ # entries in a directory, which doesn't always appear to be the
+ # case on ext3... (05 Apr 2004 agriffis)
+ epatch ${FILESDIR}/skipdots.patch
+
+ # Clean up headers to reduce warnings
+ sed -i -e 's|^#endif.*|#endif|' *.h */*.h
+}
+
+src_compile() {
+ local a=$ARCH
+ [[ $a = x86 ]] && a=i386
+
+ # The following CFLAGS are almost directly from Red Hat 8.0 and
+ # debian/rules, so assume it's okay to void out the __COPYRIGHT
+ # and __RCSID. I've checked the source and don't see the point,
+ # but whatever... (07 Feb 2004 agriffis)
+ CFLAGS="${CFLAGS} -Wall -D_GNU_SOURCE \
+ -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
+ -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"${a}\\\""
+ make -f Makefile.boot CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/share/mk
+ insinto /usr/share/mk
+ rm -f mk/*~
+ doins mk/*
+
+ mv bmake pmake
+ dobin pmake || die
+ dobin mkdep
+ mv make.1 pmake.1
+ doman mkdep.1 pmake.1
+ dodoc PSD.doc/tutorial.ms
+}