summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-09-28 14:45:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-09-28 14:45:57 +0000
commit38d7f985f97c91b3ca687876ecda48c6f0e43664 (patch)
treebb3ea16ffb7f60d79a0a5ce51c2e948fcd04ea8b /sys-devel
parentUpdate version (diff)
downloadhistorical-38d7f985f97c91b3ca687876ecda48c6f0e43664.tar.gz
historical-38d7f985f97c91b3ca687876ecda48c6f0e43664.tar.bz2
historical-38d7f985f97c91b3ca687876ecda48c6f0e43664.zip
Update version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/Manifest5
-rw-r--r--sys-devel/autoconf/autoconf-2.57a.ebuild140
-rw-r--r--sys-devel/autoconf/files/autoconf-2.57a-infopage-namechange.patch122
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.57a2
4 files changed, 267 insertions, 2 deletions
diff --git a/sys-devel/autoconf/Manifest b/sys-devel/autoconf/Manifest
index eea26bc4573e..e445dd852e7c 100644
--- a/sys-devel/autoconf/Manifest
+++ b/sys-devel/autoconf/Manifest
@@ -3,11 +3,12 @@ MD5 0e273fec6f80838f4556e7114868d8d8 autoconf-2.57.ebuild 3212
MD5 512a24f6969c9f497f2d94c77a7b549c autoconf-2.53a.ebuild 2782
MD5 0e3dddf05f2b4efa229843d9a1201410 autoconf-2.54.ebuild 3205
MD5 f73eea253e36a72484edff7fe1ca1086 autoconf-2.13-r2.ebuild 989
-MD5 b442e17e5d80e6b8024bb928bee1398b autoconf-2.57a.ebuild 3269
-MD5 41ba869f2cca29f418ca30a954a6a475 ChangeLog 4137
+MD5 154a8e475e893a398434d0b77f6bc9fc autoconf-2.57a.ebuild 3269
+MD5 f2f706827d64d4418644e9c1e6e931b0 ChangeLog 4313
MD5 98662b30b8641482848514c4b26efede autoconf-2.57-r1.ebuild 3216
MD5 28795f22763ef0683a8a1e72e8dd4646 files/ac-wrapper.pl 2133
MD5 f2802f3155defa9299baf6e5d0d79571 files/digest-autoconf-2.57a 132
+MD5 c98042870fa4228b40ce57442d91ca47 files/autoconf-2.57a-infopage-namechange.patch 5119
MD5 02c192b9ea3e4945d007a8cfde221c73 files/digest-autoconf-2.13-r2 65
MD5 ac8caa17f05e56e10927af757cf12f99 files/digest-autoconf-2.54 131
MD5 12f8fb67eaf50f87ed7825356503e8d7 files/autoconf-2.13-configure-gentoo.diff 958
diff --git a/sys-devel/autoconf/autoconf-2.57a.ebuild b/sys-devel/autoconf/autoconf-2.57a.ebuild
new file mode 100644
index 000000000000..2a603d4033a6
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.57a.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.57a.ebuild,v 1.1 2003/09/28 14:45:44 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ ~sys-devel/m4-1.4
+ dev-lang/perl"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.57a-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ perl -pi -e 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/autoconf-2.57a-infopage-namechange.patch b/sys-devel/autoconf/files/autoconf-2.57a-infopage-namechange.patch
new file mode 100644
index 000000000000..9552b333fc40
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.57a-infopage-namechange.patch
@@ -0,0 +1,122 @@
+diff -urN autoconf-2.57a/doc/Makefile.in autoconf-2.57a.info/doc/Makefile.in
+--- autoconf-2.57a/doc/Makefile.in 2003-09-28 16:42:23.267768088 +0200
++++ autoconf-2.57a.info/doc/Makefile.in 2003-09-28 16:42:47.480087256 +0200
+@@ -44,12 +44,12 @@
+ DIST_SOURCES =
+ TEXINFO_TEX = $(top_srcdir)/config/texinfo.tex
+ am__TEXINFO_TEX_DIR = $(top_srcdir)/config
+-INFO_DEPS = autoconf.info standards.info
++INFO_DEPS = autoconf25.info standards.info
+ DVIS = autoconf.dvi standards.dvi
+ PDFS = autoconf.pdf standards.pdf
+ PSS = autoconf.ps standards.ps
+ HTMLS = autoconf.html standards.html
+-TEXINFOS = autoconf.texi standards.texi
++TEXINFOS = autoconf25.texi standards.texi
+ TEXI2PDF = $(TEXI2DVI) --pdf --batch
+ DVIPS = dvips
+ am__installdirs = $(DESTDIR)$(infodir)
+@@ -116,7 +116,7 @@
+ TEXI2DVI = texi2dvi --batch
+ TEXI2HTML = texi2html
+ TEXI2HTML_FLAGS = -split_chapter
+-info_TEXINFOS = autoconf.texi standards.texi
++info_TEXINFOS = autoconf25.texi standards.texi
+ autoconf_TEXINFOS = fdl.texi install.texi
+ standards_TEXINFOS = make-stds.texi
+
+@@ -192,14 +192,14 @@
+ .texi.html:
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) --html -I $(srcdir) \
+ -o $@ $<
+-autoconf.info: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.dvi: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.pdf: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.html: autoconf.texi version.texi $(autoconf_TEXINFOS)
++autoconf25.info: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.dvi: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.pdf: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.html: autoconf25.texi version.texi $(autoconf_TEXINFOS)
+ version.texi: stamp-vti
+-stamp-vti: autoconf.texi $(top_srcdir)/configure
+- @(dir=.; test -f ./autoconf.texi || dir=$(srcdir); \
+- set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf.texi`; \
++stamp-vti: autoconf25.texi $(top_srcdir)/configure
++ @(dir=.; test -f ./autoconf25.texi || dir=$(srcdir); \
++ set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf25.texi`; \
+ echo "@set UPDATED $$1 $$2 $$3"; \
+ echo "@set UPDATED-MONTH $$2 $$3"; \
+ echo "@set EDITION $(VERSION)"; \
+@@ -430,8 +430,8 @@
+
+ html: autoconf_1.html standards_1.html
+
+-autoconf_1.html: autoconf.texi install.texi
+- $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/autoconf.texi
++autoconf_1.html: autoconf25.texi install.texi
++ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/autoconf25.texi
+
+ standards_1.html: standards.texi make-stds.texi
+ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/standards.texi
+diff -urN autoconf-2.57a/doc/autoconf.texi autoconf-2.57a.info/doc/autoconf.texi
+--- autoconf-2.57a/doc/autoconf.texi 2003-09-28 16:42:23.283765656 +0200
++++ autoconf-2.57a.info/doc/autoconf.texi 2003-09-28 16:43:17.728488800 +0200
+@@ -1,9 +1,9 @@
+ \input texinfo @c -*-texinfo-*-
+ @comment ========================================================
+ @comment %**start of header
+-@setfilename autoconf.info
++@setfilename autoconf25.info
+ @include version.texi
+-@settitle Autoconf
++@settitle Autoconf v2.5
+ @setchapternewpage odd
+ @setcontentsaftertitlepage
+ @finalout
+@@ -200,33 +200,33 @@
+
+
+
+-@dircategory Software development
++@dircategory GNU programming tools
+ @direntry
+-* Autoconf: (autoconf). Create source code configuration scripts.
++* Autoconf v2.5: (autoconf25). Create source code configuration scripts.
+ @end direntry
+
+ @dircategory Individual utilities
+ @direntry
+-* autoscan: (autoconf)autoscan Invocation.
++* autoscan: (autoconf25)autoscan Invocation.
+ Semi-automatic @file{configure.ac} writing
+-* ifnames: (autoconf)ifnames Invocation. Listing conditionals in source.
+-* autoconf: (autoconf)autoconf Invocation.
++* ifnames: (autoconf25)ifnames Invocation. Listing conditionals in source.
++* autoconf: (autoconf25)autoconf Invocation.
+ How to create configuration scripts
+-* autoreconf: (autoconf)autoreconf Invocation.
++* autoreconf: (autoconf25)autoreconf Invocation.
+ Remaking multiple @command{configure} scripts
+-* autoheader: (autoconf)autoheader Invocation.
++* autoheader: (autoconf25)autoheader Invocation.
+ How to create configuration templates
+-* autom4te: (autoconf)autom4te Invocation.
++* autom4te: (autoconf25)autom4te Invocation.
+ The Autoconf executables backbone
+-* configure: (autoconf)configure Invocation. Configuring a package.
+-* autoupdate: (autoconf)autoupdate Invocation.
++* configure: (autoconf25)configure Invocation. Configuring a package.
++* autoupdate: (autoconf25)autoupdate Invocation.
+ Automatic update of @file{configure.ac}
+-* config.status: (autoconf)config.status Invocation. Recreating configurations.
+-* testsuite: (autoconf)testsuite Invocation. Running an Autotest test suite.
++* config.status: (autoconf25)config.status Invocation. Recreating configurations.
++* testsuite: (autoconf25)testsuite Invocation. Running an Autotest test suite.
+ @end direntry
+
+ @titlepage
+-@title Autoconf
++@title Autoconf v2.5
+ @subtitle Creating Automatic Configuration Scripts
+ @subtitle for version @value{VERSION}, @value{UPDATED}
+ @author David MacKenzie
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.57a b/sys-devel/autoconf/files/digest-autoconf-2.57a
new file mode 100644
index 000000000000..469bd54bbd78
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.57a
@@ -0,0 +1,2 @@
+MD5 61297397b9c5740132c34e32d7967ac1 autoconf-2.57a.tar.bz2 839100
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844