summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-29 17:51:02 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-29 17:51:02 +0000
commit17328b803703ddaa0be2d40833bf1fe653a5b071 (patch)
tree04d3f47a12e73f190ff9d3eca05fc145c9116177 /sys-devel
parentatexit fix; remove texinfo (diff)
downloadhistorical-17328b803703ddaa0be2d40833bf1fe653a5b071.tar.gz
historical-17328b803703ddaa0be2d40833bf1fe653a5b071.tar.bz2
historical-17328b803703ddaa0be2d40833bf1fe653a5b071.zip
small fixes from gcc-3.x that will not affect anything major
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r7.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r7.ebuild b/sys-devel/gcc/gcc-2.95.3-r7.ebuild
index 7331d774c954..57173ec99846 100644
--- a/sys-devel/gcc/gcc-2.95.3-r7.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r7.ebuild,v 1.1 2002/06/29 17:44:07 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r7.ebuild,v 1.2 2002/06/29 17:51:02 azarah Exp $
TV=4.0
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz"
@@ -11,6 +11,7 @@ S=${WORKDIR}/${P}
LOC=/usr
DESCRIPTION="Modern GCC C/C++ compiler and an included, upgraded version of texinfo to boot"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
+SLOT="0"
DEPEND="virtual/glibc"
RDEPEND="virtual/glibc"
@@ -186,3 +187,14 @@ pkg_preinst() {
fi
}
+pkg_postrm() {
+ if [ ! -L ${ROOT}/lib/cpp ]
+ then
+ ln -sf /usr/bin/cpp ${ROOT}/lib/cpp
+ fi
+ if [ ! -L ${ROOT}/usr/bin/cc ]
+ then
+ ln -sf gcc ${ROOT}/usr/bin/cc
+ fi
+}
+