summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-03 09:45:28 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-03 09:45:28 +0000
commitcf8d2c8f5fdcc6d0b289887e606e27f068136b3f (patch)
treef279c0789ff57b06a2af6aeff53cf7ad15f284d1 /sys-devel/pmake
parentsyntax fix (diff)
downloadhistorical-cf8d2c8f5fdcc6d0b289887e606e27f068136b3f.tar.gz
historical-cf8d2c8f5fdcc6d0b289887e606e27f068136b3f.tar.bz2
historical-cf8d2c8f5fdcc6d0b289887e606e27f068136b3f.zip
initial import, thanks to Spider for getting 100%
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/ChangeLog12
-rw-r--r--sys-devel/pmake/files/01_all_groffpatch.patch15
-rw-r--r--sys-devel/pmake/files/02_all_mktemp.patch21
-rw-r--r--sys-devel/pmake/files/digest-pmake-1.45-r21
-rw-r--r--sys-devel/pmake/pmake-1.45-r2.ebuild57
5 files changed, 106 insertions, 0 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
new file mode 100644
index 000000000000..48a35fd94049
--- /dev/null
+++ b/sys-devel/pmake/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sys-devel/pmake
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.1 2002/12/03 09:45:28 bcowan Exp $
+
+*pmake-1.4.5-r2 (27 Nov 2002)
+
+ 27 Nov 2002; Brad Cowan <bcowan@gentoo.org> pmake-1.4.5-r2.ebuild,
+ files/digest-pmake-1.4.5-r2, ChangeLog:
+
+ Initial import, thanks to Spider's work for getting it 100% :).
+
+
diff --git a/sys-devel/pmake/files/01_all_groffpatch.patch b/sys-devel/pmake/files/01_all_groffpatch.patch
new file mode 100644
index 000000000000..fa9467ea0003
--- /dev/null
+++ b/sys-devel/pmake/files/01_all_groffpatch.patch
@@ -0,0 +1,15 @@
+--- pmake-1.45/mk/bsd.man.mk.groffpath Tue Aug 21 12:48:01 2001
++++ pmake-1.45/mk/bsd.man.mk Tue Aug 21 12:51:11 2001
+@@ -17,9 +17,9 @@
+ .endif
+ cleandir distclean: cleanman
+
+-TMACDIR?= ${DESTDIR}/usr/share/groff/tmac
+-CATDEPS?= ${TMACDIR}/tmac.andoc \
+- ${TMACDIR}/tmac.doc \
++TMACDIR?= ${DESTDIR}/usr/share/groff/1.17.2/tmac
++CATDEPS?= ${TMACDIR}/andoc.tmac \
++ ${TMACDIR}/doc.tmac \
+ ${TMACDIR}/mdoc/doc-ditroff \
+ ${TMACDIR}/mdoc/doc-common \
+ ${TMACDIR}/mdoc/doc-nroff \
diff --git a/sys-devel/pmake/files/02_all_mktemp.patch b/sys-devel/pmake/files/02_all_mktemp.patch
new file mode 100644
index 000000000000..1e7726a7d6a3
--- /dev/null
+++ b/sys-devel/pmake/files/02_all_mktemp.patch
@@ -0,0 +1,21 @@
+--- pmake-1.45/mkdep.mktemp Fri May 11 14:08:35 2001
++++ pmake-1.45/mkdep Fri May 11 14:10:03 2001
+@@ -68,17 +68,9 @@
+ exit 1
+ fi
+
+-DTMP=/tmp/mkdep$$
++DTMP=`/bin/mktemp -d /tmp/mkdepXXXXXX`
+ TMP=$DTMP/mkdep
+
+-um=`umask`
+-umask 022
+-if ! mkdir $DTMP ; then
+- echo failed to create tmp dir $DTMP
+- exit 1
+-fi
+-
+-umask $um
+ trap 'rm -rf $DTMP ; trap 2 ; kill -2 $$' 1 2 3 13 15
+
+ if [ x$pflag = x ]; then
diff --git a/sys-devel/pmake/files/digest-pmake-1.45-r2 b/sys-devel/pmake/files/digest-pmake-1.45-r2
new file mode 100644
index 000000000000..110fde3e22d0
--- /dev/null
+++ b/sys-devel/pmake/files/digest-pmake-1.45-r2
@@ -0,0 +1 @@
+MD5 c0f21ad413abbb2fc76ec0d4d426578f pmake_1.45-11.tar.gz 252673
diff --git a/sys-devel/pmake/pmake-1.45-r2.ebuild b/sys-devel/pmake/pmake-1.45-r2.ebuild
new file mode 100644
index 000000000000..0959ec0dea01
--- /dev/null
+++ b/sys-devel/pmake/pmake-1.45-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.45-r2.ebuild,v 1.1 2002/12/03 09:45:28 bcowan Exp $
+
+IUSE=""
+
+inherit eutils
+EPATCH_SOURCE="${FILESDIR}"
+
+MY_P="${PN}_${PV}-11"
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="BSD build tool to create programs in parallel"
+HOMEPAGE="http://www.netbsd.org/"
+SRC_URI="http://cvs.gentoo.org/~bcowan/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch
+
+ mv Makefile.boot Makefile.bootorig
+ sed 's/MACHINE=sun/MACHINE=gentoo/g' Makefile.bootorig > Makefile.bootor
+ use x86 && sed 's/MACHINE_ARCH=sparc/MACHINE_ARCH=i386/g' Makefile.bootor > Makefile.boot
+ use alpha && sed 's/MACHINE_ARCH=sparc/MACHINE_ARCH=alpha/g' Makefile.bootor > Makefile.boot
+ use ppc && sed 's/MACHINE_ARCH=sparc/MACHINE_ARCH=ppc/g' Makefile.bootor > Makefile.boot
+ use sparc64 && sed 's/MACHINE_ARCH=sparc/MACHINE_ARCH=sparc64/g' Makefile.bootor > Makefile.boot
+}
+
+src_compile() {
+ make -f Makefile.boot CFLAGS="-O2 -g -Wall -D_GNU_SOURCE -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I."
+}
+
+src_install() {
+ dodir /usr/share/mk
+ insinto /usr/share/mk
+ rm -f mk/*~
+ doins mk/*
+
+ mv bmake pmake
+ dobin pmake
+ dobin mkdep
+ mv make.1 pmake.1
+ doman mkdep.1 pmake.1
+ dodoc PSD.doc/tutorial.ms
+
+}