summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:15:06 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:15:06 +0000
commit28552a5fdcd4cc83bddc0d4c58c6ae69514461bf (patch)
tree9bb3e7b6927997dcee4d8b8f9eae58b3819072d9 /sys-devel/m4
parentPrepared for rc3 (diff)
downloadhistorical-28552a5fdcd4cc83bddc0d4c58c6ae69514461bf.tar.gz
historical-28552a5fdcd4cc83bddc0d4c58c6ae69514461bf.tar.bz2
historical-28552a5fdcd4cc83bddc0d4c58c6ae69514461bf.zip
Prepared for rc3
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/m4-1.4o-r1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-devel/m4/m4-1.4o-r1.ebuild b/sys-devel/m4/m4-1.4o-r1.ebuild
index 88cc8bff2dbd..85d992c0f321 100644
--- a/sys-devel/m4/m4-1.4o-r1.ebuild
+++ b/sys-devel/m4/m4-1.4o-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r1.ebuild,v 1.3 2000/09/15 20:09:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r1.ebuild,v 1.4 2000/11/30 23:15:06 achim Exp $
P=m4-1.4o
A=${P}.tar.gz
@@ -9,24 +9,24 @@ S=${WORKDIR}/${P}
DESCRIPTION="GNU macro processor"
SRC_URI="ftp://ftp.seindal.dk/gnu/${A}"
HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+DEPEND=">=sys-libs/glibc-2.1.3"
src_compile() {
- try ./configure --prefix=/usr --with-modules --with-catgets --host=${CHOST}
- try make
+ try ./configure --prefix=/usr --with-modules --host=${CHOST}
+ try make ${MAKEOPTS}
}
-src_install() {
- into /usr
+src_install() {
+
cd ${S}
- try make prefix=${D}/usr install
- prepman
- prepinfo
- insinto /usr/share/m4
- cd ${S}/examples
- doins *.m4
- cd ${S}
-
- dodoc AUTHORS BACKLOG COPYING NEWS README THANKS TODO
+ try make DESTDIR=${D} install
+ rm -rf ${D}/usr/include ${D}/usr/lib
+ dodoc AUTHORS BACKLOG ChangeLog COPYING NEWS README* THANKS TODO
+ docinto modules
+ dodoc modules/README modules/TODO
+ docinto html
+ dodoc examples/WWW/*.htm
+
}