summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-04 18:36:29 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-04 18:36:29 +0000
commit2b059e3f9c2f42362466b7aa766a9553a37fe487 (patch)
treeb596b20942968f51a152db96312b04e547896d83 /sys-devel/llvm/llvm-2.7.ebuild
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #332527 (diff)
downloadhistorical-2b059e3f9c2f42362466b7aa766a9553a37fe487.tar.gz
historical-2b059e3f9c2f42362466b7aa766a9553a37fe487.tar.bz2
historical-2b059e3f9c2f42362466b7aa766a9553a37fe487.zip
Also fix libEnhancedDisassembly, which is only built on Darwin 10 (Mac OS X Snow Leopard)
Package-Manager: portage-2.2.01.15553-prefix/cvs/Darwin powerpc
Diffstat (limited to 'sys-devel/llvm/llvm-2.7.ebuild')
-rw-r--r--sys-devel/llvm/llvm-2.7.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-2.7.ebuild b/sys-devel/llvm/llvm-2.7.ebuild
index 36112354298f..1bc0c201f84b 100644
--- a/sys-devel/llvm/llvm-2.7.ebuild
+++ b/sys-devel/llvm/llvm-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.6 2010/09/03 17:49:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.7 2010/09/04 18:36:29 grobian Exp $
EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -153,7 +153,9 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{LLVMHello,LTO,profile_rt}.dylib ; do
+ for lib in lib{EnhancedDisassembly,LLVMHello,LTO,profile_rt}.dylib ; do
+ # libEnhancedDisassembly is Darwin10 only
+ [[ -f ${ED}/usr/lib/${lib} ]] || continue
install_name_tool -id "${EPREFIX}"/usr/lib/${lib} \
"${ED}"/usr/lib/${lib}
done