summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-29 09:42:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-29 09:42:58 +0000
commit2bdbeae284e631a65df0ebc5810492a9683ce3f4 (patch)
treee89bbe4cc01d08cffeaae5dfc65a1662cd7666f4 /sys-devel/libtool
parentuclibc isnt special (diff)
downloadhistorical-2bdbeae284e631a65df0ebc5810492a9683ce3f4.tar.gz
historical-2bdbeae284e631a65df0ebc5810492a9683ce3f4.tar.bz2
historical-2bdbeae284e631a65df0ebc5810492a9683ce3f4.zip
build & install manpages
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/Manifest10
-rw-r--r--sys-devel/libtool/libtool-1.5.20.ebuild14
2 files changed, 20 insertions, 4 deletions
diff --git a/sys-devel/libtool/Manifest b/sys-devel/libtool/Manifest
index 4792d4bca22d..536c4f7dc461 100644
--- a/sys-devel/libtool/Manifest
+++ b/sys-devel/libtool/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 d32b422eba97956ff1c4b2d270460b9a ChangeLog 15690
MD5 8ad4f6ed8863c26c4ac562e1d00e6db1 files/1.4.3/libtool-1.2f-cache.patch 698
MD5 55544e163772c87195b893d27e00a0f8 files/1.4.3/libtool-1.3.5-mktemp.patch 642
@@ -33,3 +36,10 @@ MD5 e48784e20efad8d2437f1c271104a4b4 libtool-1.5.16.ebuild 5178
MD5 50b3b9fe1d346665231c739e48d616b6 libtool-1.5.18-r1.ebuild 5181
MD5 200271efe4b1303894b7b3c617a4ddef libtool-1.5.20.ebuild 5104
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDY0Q3gIKl8Uu19MoRAmhVAJ9GOR2gK/AoNzF3L7eIVKpaCUDxCgCfUkBa
+sTse/GtvYC6wieibnKIlnI0=
+=2E0a
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/libtool/libtool-1.5.20.ebuild b/sys-devel/libtool/libtool-1.5.20.ebuild
index b61b5868b59b..3acc82290dfa 100644
--- a/sys-devel/libtool/libtool-1.5.20.ebuild
+++ b/sys-devel/libtool/libtool-1.5.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.20.ebuild,v 1.8 2005/10/18 13:03:11 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.20.ebuild,v 1.9 2005/10/29 09:42:58 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils
@@ -13,11 +13,11 @@ SLOT="1.5"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh sparc x86"
IUSE=""
-DEPEND="sys-devel/gnuconfig
+RDEPEND="sys-devel/gnuconfig
>=sys-devel/autoconf-2.59
>=sys-devel/automake-1.9"
-# the autoconf dep is due to it complaining 'configure.ac:55: error: Autoconf version 2.58 or higher is required'
-# the automake dep is due to Bug #46037
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
lt_setup() {
export WANT_AUTOCONF=2.5
@@ -142,6 +142,12 @@ src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+ local x
+ for x in libtool libtoolize ; do
+ help2man ${x} > ${x}.1
+ doman ${x}.1
+ done
+
for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
rm -f "${x}" ; ln -sf ../gnuconfig/$(basename "${x}") "${x}"
done