summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-11 17:57:20 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-11 17:57:20 +0000
commit8ed8a1b222aa7970c8d93514c129690e560bbe50 (patch)
tree39a4f21ceae10290e6f4343901abb1111ba3f506 /sys-devel/gettext
parentispell->new aspell (diff)
downloadhistorical-8ed8a1b222aa7970c8d93514c129690e560bbe50.tar.gz
historical-8ed8a1b222aa7970c8d93514c129690e560bbe50.tar.bz2
historical-8ed8a1b222aa7970c8d93514c129690e560bbe50.zip
fix weird header problem
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/ChangeLog7
-rw-r--r--sys-devel/gettext/gettext-0.11.1.ebuild37
2 files changed, 29 insertions, 15 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 4a06155f308b..efe2bbcb0e61 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.7 2002/08/16 18:35:37 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.8 2002/09/11 17:57:20 azarah Exp $
+
+ 11 Sep 2002; Martin Schlemmer <azarah@gentoo.org> gettext-0.11.1.ebuild :
+
+ Make sure that no headers is installed. Seems like this happened in
+ very rare instances, bug #7682.
*gettext-0.11.5 (16 Aug 2002)
diff --git a/sys-devel/gettext/gettext-0.11.1.ebuild b/sys-devel/gettext/gettext-0.11.1.ebuild
index 94c82f5d1983..af228cfd087e 100644
--- a/sys-devel/gettext/gettext-0.11.1.ebuild
+++ b/sys-devel/gettext/gettext-0.11.1.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.11.1.ebuild,v 1.8 2002/08/14 11:56:44 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.11.1.ebuild,v 1.9 2002/09/11 17:57:20 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GNU locale utilities"
SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gettext/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
src_unpack() {
unpack ${A}
+
cd ${S}/misc
cp Makefile.in Makefile.in.orig
#This fix stops gettext from invoking emacs to install the po mode
@@ -20,21 +22,28 @@ src_unpack() {
}
src_compile() {
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- ./configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --with-included-gettext --disable-shared --host=${CHOST} ${myconf} || die
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --with-included-gettext \
+ --disable-shared \
+ ${myconf} || die
+
emake || die
}
src_install() {
- make prefix=${D}/usr infodir=${D}/usr/share/info mandir=${D}/usr/share/man lispdir=${D}/usr/share/emacs/site-lisp install || die
- dodoc AUTHORS BUGS COPYING ChangeLog DISCLAIM NEWS README* THANKS TODO
+ einstall \
+ lispdir=${D}/usr/share/emacs/site-lisp \
+ || die
+
+ exeopts -m0755
+ exeinto /usr/bin
+ doexe misc/gettextize
#glibc includes gettext; this isn't needed anymore
- rm -rf ${D}/usr/lib/*
+ rm -rf ${D}/usr/{include,lib}/*
#again, installed by glibc
rm -rf ${D}/usr/share/locale/locale.alias
@@ -44,7 +53,7 @@ src_install() {
mv ${D}/usr/doc/gettext ${D}/usr/share/doc/${PF}/html
rm -rf ${D}/usr/doc
fi
- exeopts -m0755
- exeinto /usr/bin
- doexe misc/gettextize
+
+ dodoc AUTHORS BUGS COPYING ChangeLog DISCLAIM NEWS README* THANKS TODO
}
+