summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-15 23:06:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-15 23:06:55 +0000
commit20b925cd2a8f60c24c947cdf46c34d1595fc598f (patch)
tree3ec79f5f2d356947d629d9139e3a01196ae90a43 /sys-devel/gcc
parentold (diff)
downloadhistorical-20b925cd2a8f60c24c947cdf46c34d1595fc598f.tar.gz
historical-20b925cd2a8f60c24c947cdf46c34d1595fc598f.tar.bz2
historical-20b925cd2a8f60c24c947cdf46c34d1595fc598f.zip
Bump weekly 4.2 snapshot.
Package-Manager: portage-2.1.1_pre2-r8
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200607153
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild62
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 88558531bb28..8025a133ce1a 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.562 2006/07/13 11:34:13 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.563 2006/07/15 23:06:55 vapier Exp $
+
+*gcc-4.2.0_alpha20060715 (15 Jul 2006)
+
+ 15 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+ +gcc-4.2.0_alpha20060715.ebuild:
+ Bump weekly 4.2 snapshot.
13 Jul 2006; Kevin F. Quinn <kevquinn@gentoo.org> gcc-3.3.5-r1.ebuild,
gcc-3.3.5.20050130-r1.ebuild, gcc-3.3.6.ebuild, gcc-3.3.6-r1.ebuild,
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060715 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060715
new file mode 100644
index 000000000000..72b86754c15b
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060715
@@ -0,0 +1,3 @@
+MD5 06dca73d3dd192d333c4f03d81d81a99 gcc-4.2-20060715.tar.bz2 39949045
+RMD160 5160b3f61598cc5fae57982b3869eaf218a027f3 gcc-4.2-20060715.tar.bz2 39949045
+SHA256 3c633c403eb3315ca840e2fd3a57fe5e5ea626d37756e82849781c7d2a90548e gcc-4.2-20060715.tar.bz2 39949045
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
new file mode 100644
index 000000000000..a03651103061
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild,v 1.1 2006/07/15 23:06:55 vapier Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ virtual/libiconv
+ fortran? (
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.2.0_p10
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}