summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-26 03:19:27 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-26 03:19:27 +0000
commit9ab554a55dfeab141816c568bcbd81b40bd01b00 (patch)
treeae396450f9b1205d7da7cb806f8a8499a8d7517f /sys-devel/gcc-config
parentUse vm-mime-8bit-composition-charset to determine charset for sending. (diff)
downloadhistorical-9ab554a55dfeab141816c568bcbd81b40bd01b00.tar.gz
historical-9ab554a55dfeab141816c568bcbd81b40bd01b00.tar.bz2
historical-9ab554a55dfeab141816c568bcbd81b40bd01b00.zip
old
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.4.00
-rw-r--r--sys-devel/gcc-config/gcc-config-1.4.0.ebuild52
2 files changed, 0 insertions, 52 deletions
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.4.0 b/sys-devel/gcc-config/files/digest-gcc-config-1.4.0
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.4.0
+++ /dev/null
diff --git a/sys-devel/gcc-config/gcc-config-1.4.0.ebuild b/sys-devel/gcc-config/gcc-config-1.4.0.ebuild
deleted file mode 100644
index 8a23c8e31aec..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.4.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.4.0.ebuild,v 1.7 2007/08/22 16:44:16 vapier Exp $
-
-inherit flag-o-matic toolchain-funcs multilib
-
-# Version of .c wrapper to use
-W_VER="1.5.0"
-
-DESCRIPTION="Utility to change the gcc compiler being used"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="!app-admin/eselect-compiler"
-
-S=${WORKDIR}
-
-src_compile() {
- strip-flags
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wall -o wrapper \
- "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
-}
-
-src_install() {
- newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
- sed -i \
- -e "s:PORTAGE-VERSION:${PVR}:g" \
- -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
- "${D}"/usr/bin/${PN}
-
- exeinto /usr/$(get_libdir)/misc
- newexe wrapper gcc-config || die "install wrapper"
-}
-
-pkg_postinst() {
- # Do we have a valid multi ver setup ?
- if gcc-config --get-current-profile &>/dev/null ; then
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
- [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
- gcc-config $(/usr/bin/gcc-config --get-current-profile)
- fi
-
- # Make sure old versions dont exist #79062
- rm -f "${ROOT}"/usr/sbin/gcc-config
-}