summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-17 22:53:41 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-17 22:53:41 +0000
commite3132c6c4534d01bbbd64aa0bca9e15bbc008884 (patch)
treed2595b1040dd4bc8fb7742ff616394a2be9da3f8 /sys-devel/flex/flex-2.5.31.ebuild
parentVersion bumped. Changed SRC_URI to gentoo mirror (diff)
downloadhistorical-e3132c6c4534d01bbbd64aa0bca9e15bbc008884.tar.gz
historical-e3132c6c4534d01bbbd64aa0bca9e15bbc008884.tar.bz2
historical-e3132c6c4534d01bbbd64aa0bca9e15bbc008884.zip
Version bumped. Changed SRC_URI to gentoo mirror
Diffstat (limited to 'sys-devel/flex/flex-2.5.31.ebuild')
-rw-r--r--sys-devel/flex/flex-2.5.31.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-devel/flex/flex-2.5.31.ebuild b/sys-devel/flex/flex-2.5.31.ebuild
new file mode 100644
index 000000000000..1914a72ba3fb
--- /dev/null
+++ b/sys-devel/flex/flex-2.5.31.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.31.ebuild,v 1.1 2003/04/17 22:53:29 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU lexical analyser generator"
+SRC_URI="mirror://sourceforge/lex/${P}.tar.bz2"
+HOMEPAGE="http://www.gnu.org/software/flex/flex.html"
+
+SLOT="0"
+LICENSE="FLEX"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+ myconf=""
+
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake || make || die
+ else
+ emake LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS ONEWS README* RoadMap THANKS TODO
+ else
+ rm -rf ${D}/usr/share ${D}/usr/include ${D}/usr/lib
+ fi
+
+ dosym flex /usr/bin/lex
+}
+