summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-09-06 22:22:34 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-09-06 22:22:34 +0000
commit0d665a2f05b61cc238b0f475b53ac6145053f5fc (patch)
tree69cef3db8c21c4ba96e7f4010c7c44480bf8f06d /sys-devel/bison
parentrepoman: trim trailing whitespace (diff)
downloadhistorical-0d665a2f05b61cc238b0f475b53ac6145053f5fc.tar.gz
historical-0d665a2f05b61cc238b0f475b53ac6145053f5fc.tar.bz2
historical-0d665a2f05b61cc238b0f475b53ac6145053f5fc.zip
Update version
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog8
-rw-r--r--sys-devel/bison/Manifest10
-rw-r--r--sys-devel/bison/bison-1.875.ebuild69
-rw-r--r--sys-devel/bison/files/bison-1.32-extfix.patch28
-rw-r--r--sys-devel/bison/files/bison-1.875-gccerror.patch50
-rw-r--r--sys-devel/bison/files/digest-bison-1.8751
6 files changed, 162 insertions, 4 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 1b975ab2968f..ac2f3a1e8e7d 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.16 2003/09/02 19:09:36 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.17 2003/09/06 22:22:21 azarah Exp $
+
+*bison-1.875 (07 Sep 2003)
+
+ 07 Sep 2003; Martin Schlemmer <azarah@gentoo.org> bison-1.875.ebuild,
+ files/bison-1.32-extfix.patch, files/bison-1.875-gccerror.patch:
+ Update version.
02 Sep 2003; Martin Holzer <mholzer@gentoo.org> bison-1.34-r1.ebuild,
bison-1.35.ebuild, bison-1.75.ebuild:
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 2d3dff2d0723..d391c4c68b6d 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -1,7 +1,11 @@
-MD5 760f84c2423fa0b1f06ed3949ee1a8b1 ChangeLog 2643
+MD5 d5c8185871d1fb88a98f59353ad7aa25 bison-1.75.ebuild 1122
+MD5 14fe58f5d15896c8bf0ec4b74ae0eb51 ChangeLog 2828
MD5 6237bb7c742aaabfba528d8521f856da bison-1.34-r1.ebuild 1190
MD5 cabead588b35fd0ef81765e0db4d9cf2 bison-1.35.ebuild 1297
-MD5 d5c8185871d1fb88a98f59353ad7aa25 bison-1.75.ebuild 1122
-MD5 85dbbe1a9f32abae54cacd04aaa80709 files/digest-bison-1.34-r1 63
+MD5 b850847d553e14f66e0ea5ba27228ba2 bison-1.875.ebuild 1462
+MD5 4a875793f3bd808692002c152e5e26c4 files/digest-bison-1.875 64
MD5 9c4ca0c28c5762cc799cc3e56f51d54e files/digest-bison-1.35 63
+MD5 644a4912da3e5107f509022f173ec146 files/bison-1.875-gccerror.patch 1538
+MD5 61b224a9eaf1ae7f77c2d1456d8fda87 files/bison-1.32-extfix.patch 1170
MD5 ccaa497656beb47a684c2e33084522b0 files/digest-bison-1.75 63
+MD5 85dbbe1a9f32abae54cacd04aaa80709 files/digest-bison-1.34-r1 63
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
new file mode 100644
index 000000000000..7684d55f1477
--- /dev/null
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.1 2003/09/06 22:22:21 azarah Exp $
+
+IUSE="nls static build" # icc"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+# do not compile xfree
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="nls? ( sys-devel/gettext )"
+# icc? ( dev-lang/icc )"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.32-extfix.patch
+ epatch ${FILESDIR}/${PN}-1.875-gccerror.patch
+}
+
+src_compile() {
+
+# use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
+ local myconf=
+
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS="-static" || die
+ fi
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ datadir=/usr/share \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ install || die
+
+ # This one is installed by dev-util/yacc
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison
+
+ # We do not need this.
+ rm -f ${D}/usr/lib/liby.a
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-devel/bison/files/bison-1.32-extfix.patch b/sys-devel/bison/files/bison-1.32-extfix.patch
new file mode 100644
index 000000000000..363d038d8a52
--- /dev/null
+++ b/sys-devel/bison/files/bison-1.32-extfix.patch
@@ -0,0 +1,28 @@
+2002-02-15 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com>
+
+ * src/files (compute_exts_from_gf, compute_exts_from_src): Handle
+ the case where header_extension is the same as src_extension, aka
+ handle -d -o <file> where <file> doesn't have a known EXT to
+ transform. e.g. if <file> is <something>.yxx, set the
+ header_extension to <something>.yxx.h, as would do bison 1.28.
+
+--- bison-1.32/src/files.c.extfix Mon Jan 21 16:41:46 2002
++++ bison-1.32/src/files.c Fri Feb 15 15:40:43 2002
+@@ -288,6 +288,8 @@ compute_exts_from_gf (const char *ext)
+ src_extension = tr (src_extension, 'Y', 'C');
+ header_extension = tr (ext, 'y', 'h');
+ header_extension = tr (header_extension, 'Y', 'H');
++ if (!strcmp (header_extension, src_extension))
++ header_extension = concat2 (src_extension, ".h");
+ }
+
+ /* Computes extensions from the given c source file extension. */
+@@ -300,6 +302,8 @@ compute_exts_from_src (const char *ext)
+ src_extension = xstrdup (ext);
+ header_extension = tr (ext, 'c', 'h');
+ header_extension = tr (header_extension, 'C', 'H');
++ if (!strcmp (header_extension, src_extension))
++ header_extension = concat2 (src_extension, ".h");
+ }
+
+
diff --git a/sys-devel/bison/files/bison-1.875-gccerror.patch b/sys-devel/bison/files/bison-1.875-gccerror.patch
new file mode 100644
index 000000000000..65cfc03b1981
--- /dev/null
+++ b/sys-devel/bison/files/bison-1.875-gccerror.patch
@@ -0,0 +1,50 @@
+--- bison-1.875/data/yacc.c.gccerror 2002-12-28 09:36:02.000000000 +0100
++++ bison-1.875/data/yacc.c 2003-06-24 18:05:35.000000000 +0200
+@@ -465,7 +465,15 @@
+
+ #define YYACCEPT goto yyacceptlab
+ #define YYABORT goto yyabortlab
+-#define YYERROR goto yyerrlab1
++#define YYERROR ]b4_location_if([do \
++ { \
++ yylerrsp = yylsp; \
++ *++yylerrsp = yyloc; \
++ goto yyerrlab1; \
++ } \
++ while (0)],
++ [goto yyerrlab1])[
++
+
+ /* Like YYERROR except do call yyerror. This remains here temporarily
+ to ease the transition to the new meaning of YYERROR, for GCC.
+@@ -1103,29 +1111,13 @@
+
+ /* Else will try to reuse lookahead token after shifting the error
+ token. */
+- goto yyerrlab2;
++ goto yyerrlab1;
+
+
+ /*----------------------------------------------------.
+ | yyerrlab1 -- error raised explicitly by an action. |
+ `----------------------------------------------------*/
+ yyerrlab1:
+-
+- /* Suppress GCC warning that yyerrlab1 is unused when no action
+- invokes YYERROR. */
+-#if defined (__GNUC_MINOR__) && 2093 <= (__GNUC__ * 1000 + __GNUC_MINOR__)
+- __attribute__ ((__unused__))
+-#endif
+-
+-]b4_location_if([ yylerrsp = yylsp;
+- *++yylerrsp = yyloc;])[
+- goto yyerrlab2;
+-
+-
+-/*---------------------------------------------------------------.
+-| yyerrlab2 -- pop states until the error token can be shifted. |
+-`---------------------------------------------------------------*/
+-yyerrlab2:
+ yyerrstatus = 3; /* Each real token shifted decrements this. */
+
+ for (;;)
diff --git a/sys-devel/bison/files/digest-bison-1.875 b/sys-devel/bison/files/digest-bison-1.875
new file mode 100644
index 000000000000..f77cfa43baad
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-1.875
@@ -0,0 +1 @@
+MD5 b7f8027b249ebd4dd0cc948943a71af0 bison-1.875.tar.bz2 814922