summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-08 00:42:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-08 00:42:05 +0000
commit5563e8fd46703da3c6c6dc014842508efffb9021 (patch)
tree0a4d2c46fe70cb476d4b0b0be86f7950eff4fd0d /sys-devel/autoconf
parentversion bump to force re-emerges (diff)
downloadhistorical-5563e8fd46703da3c6c6dc014842508efffb9021.tar.gz
historical-5563e8fd46703da3c6c6dc014842508efffb9021.tar.bz2
historical-5563e8fd46703da3c6c6dc014842508efffb9021.zip
old
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/autoconf-2.59-r5.ebuild142
-rw-r--r--sys-devel/autoconf/files/ac-wrapper.pl83
-rw-r--r--sys-devel/autoconf/files/autoconf-2.13-configure-gentoo.diff27
-rw-r--r--sys-devel/autoconf/files/autoconf-2.13-configure.in-gentoo.diff18
-rw-r--r--sys-devel/autoconf/files/autoconf-2.58-infopage-namechange.patch114
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.59-r52
6 files changed, 0 insertions, 386 deletions
diff --git a/sys-devel/autoconf/autoconf-2.59-r5.ebuild b/sys-devel/autoconf/autoconf-2.59-r5.ebuild
deleted file mode 100644
index 6eaa57349190..000000000000
--- a/sys-devel/autoconf/autoconf-2.59-r5.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.59-r5.ebuild,v 1.3 2005/01/02 23:58:57 ciaranm Exp $
-
-inherit eutils
-
-OLD_PV="2.13"
-OLD_P="${PN}-${OLD_PV}"
-OLD_S="${WORKDIR}/${OLD_P}"
-DESCRIPTION="Used to create autoconfiguration files"
-HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
-SRC_URI="http://ftp.gnu.org/gnu/${PN}/${P}.tar.bz2
- mirror://gnu/${PN}/${P}.tar.bz2
- mirror://gnu/${PN}/${OLD_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2.5"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-DEPEND=">=sys-apps/texinfo-4.3
- =sys-devel/m4-1.4*
- dev-lang/perl"
-
-src_unpack() {
- unpack ${A}
-
- cd ${OLD_S}
- epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
- epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
-
- cd ${S}
- # Enable both autoconf-2.1 and autoconf-2.5 info pages
- epatch ${FILESDIR}/${PN}-2.58-infopage-namechange.patch
- ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
-}
-
-src_compile() {
- #
- # ************ autoconf-2.5x ************
- #
- cd ${S}
- ./configure --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --target=${CHOST} || die
-
- emake || die
-
- #
- # ************ autoconf-2.13 ************
- #
- cd ${OLD_S}
-
- sed -i 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
- cp autoconf.texi autoconf.texi.orig
- sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
- autoconf.texi.orig > autoconf.texi
-
- ./configure --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --target=${CHOST} || die
-
- emake || die
-}
-
-src_install() {
- # install wrapper script for autodetecting the proper version
- # to use.
- exeinto /usr/lib/${PN}
- doexe ${FILESDIR}/ac-wrapper.pl
- dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
-
- #
- # ************ autoconf-2.5x ************
- #
-
- # need to use 'DESTDIR' here, else perl stuff puke
- cd ${S}
- make DESTDIR=${D} \
- install || die
-
- for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
- do
- mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
- done
- # new in 2.5x
- dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
-
-# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
-
- docinto ${PV}
- dodoc AUTHORS BUGS NEWS README TODO THANKS
- dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
-
- #
- # ************ autoconf-2.13 ************
- #
-
- # need to use 'prefix' here, else we get sandbox problems
- cd ${OLD_S}
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
- do
- mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
- dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
- done
-
- docinto ${OLD_PV}
- dodoc AUTHORS NEWS README TODO
- dodoc ChangeLog ChangeLog.0 ChangeLog.1
-
- # from binutils
- rm -f ${D}/usr/share/info/standards.info*
-}
-
-pkg_preinst() {
- # remove these to make sure symlinks install properly if old versions
- # was binaries
- for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
- do
- if [ -e ${ROOT}/usr/bin/${x} ]
- then
- rm -f ${ROOT}/usr/bin/${x}
- fi
- done
-}
-
-pkg_postinst() {
- echo
- einfo "Please note that the 'WANT_AUTOCONF_?_?=1' have changed to:"
- echo
- einfo " WANT_AUTOCONF=<required version>"
- echo
- einfo "For instance: WANT_AUTOCONF=2.5"
- echo
-}
diff --git a/sys-devel/autoconf/files/ac-wrapper.pl b/sys-devel/autoconf/files/ac-wrapper.pl
deleted file mode 100644
index 984ce670f378..000000000000
--- a/sys-devel/autoconf/files/ac-wrapper.pl
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/usr/bin/perl
-#
-#
-# Guillaume Cottenceau (gc@mandrakesoft.com)
-#
-# Copyright 2001 MandrakeSoft
-#
-# This software may be freely redistributed under the terms of the GNU
-# public license.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-#
-#
-# Executes the correct autoconf version.
-#
-# - defaults to autoconf-2.13
-# - runs autoconf-2.5x if it exists and...
-# - envvar WANT_AUTOCONF is set to `2.5'
-# -or-
-# - configure.ac is present
-# -or-
-# - `configure.in' contains AC_PREREQ and the value's 3 first letters
-# are stringwise greater than '2.13'
-# -or-
-# - `configure' is already present and was generated by autoconf greater than
-# '2.13'
-# -or-
-# - `Makefile.in' was generated by automake-1.6 or superior, which
-# specifically needs autoconf-2.5x
-#
-
-#use MDK::Common;
-
-sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
-sub ac_version {
- return ((@versions = cat_(shift) =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '');
-}
-
-my $binary = "$0-2.13";
-my $binary_new = "$0-2.5x";
-
-# Autoconf is really getting out of hand, so rather start supporting
-# WANT_AUTOCONF = "2.5" the like. Unfortunately it override the old
-# variables, so if not set, just convert the old variables ....
-if ($ENV{WANT_AUTOCONF} eq "") {
- if ($ENV{WANT_AUTOCONF_2_1}) {
- $ENV{WANT_AUTOCONF} = '2.1';
- } elsif ($ENV{WANT_AUTOCONF_2_5}) {
- $ENV{WANT_AUTOCONF} = '2.5';
- }
-}
-
-if ($ENV{WANT_AUTOCONF} ne '2.1') {
- if ((! -x $binary) # handle stuff like autom4te, where only 2.5x have the binary
- || (-x $binary_new # user may have only 2.13
- && (($ENV{WANT_AUTOCONF} eq '2.5')
- || -r 'configure.ac'
- || ac_version('configure.in') gt '2.13'
- || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.13'
- || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
- || ac_version('aclocal.m4') gt '2.13'))) {
- $ENV{WANT_AUTOCONF} = '2.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
- $binary = $binary_new;
- } else {
- $ENV{WANT_AUTOCONF} = '2.1'; # for further consistency
- }
-}
-
-# Set AUTOM4TE to the proper version (bug #40983).
-# Do not set it for 2.13 though, as it does not ship autom4te.
-if(($ENV{AUTOM4TE} eq "")
- && ($ENV{WANT_AUTOCONF} = '2.5')
- && ($0 ne 'autom4te')) {
- $ENV{AUTOM4TE} = "autom4te-2.5x";
-}
-
-$ENV{WANT_ACWRAPPER_DEBUG} and print STDERR "ac-wrapper: will execute <$binary>\n";
-
-exec $binary, @ARGV;
-
-die "ac-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/autoconf/files/autoconf-2.13-configure-gentoo.diff b/sys-devel/autoconf/files/autoconf-2.13-configure-gentoo.diff
deleted file mode 100644
index 9188ffdad024..000000000000
--- a/sys-devel/autoconf/files/autoconf-2.13-configure-gentoo.diff
+++ /dev/null
@@ -1,27 +0,0 @@
---- configure.orig Wed Feb 28 20:51:53 2001
-+++ configure Wed Feb 28 20:52:03 2001
-@@ -654,12 +654,10 @@
- echo "$ac_t""no" 1>&6
- fi
-
--if test "$PERL" != no; then
-- SCRIPTS=autoscan
--else
-- echo "configure: warning: autoscan will not be built since perl is not found" 1>&2
-+if test "$PERL" = no; then
-+ PERL=/usr/bin/perl
- fi
--
-+SCRIPTS=autoscan
- ac_aux_dir=
- for ac_dir in $srcdir $srcdir/.. $srcdir/../..; do
- if test -f $ac_dir/install-sh; then
-@@ -691,7 +689,7 @@
- # SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff"
- # ./install, which can be erroneously created by make from ./install.sh.
- echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
--echo "configure:695: checking for a BSD compatible install" >&5
-+echo "configure:693: checking for a BSD compatible install" >&5
- if test -z "$INSTALL"; then
- if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
diff --git a/sys-devel/autoconf/files/autoconf-2.13-configure.in-gentoo.diff b/sys-devel/autoconf/files/autoconf-2.13-configure.in-gentoo.diff
deleted file mode 100644
index a8b505897ac2..000000000000
--- a/sys-devel/autoconf/files/autoconf-2.13-configure.in-gentoo.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig Wed Feb 28 20:53:24 2001
-+++ configure.in Wed Feb 28 20:53:28 2001
-@@ -14,12 +14,10 @@
- AC_PATH_PROG(PERL, perl, no)
- AC_SUBST(PERL)dnl
- AC_SUBST(SCRIPTS)dnl
--if test "$PERL" != no; then
-- SCRIPTS=autoscan
--else
-- AC_MSG_WARN(autoscan will not be built since perl is not found)
-+if test "$PERL" = no; then
-+ PERL=/usr/bin/perl
- fi
--
-+SCRIPTS=autoscan
- AC_PROG_INSTALL
-
- # Work with the GNU or Cygnus source tree layout.
diff --git a/sys-devel/autoconf/files/autoconf-2.58-infopage-namechange.patch b/sys-devel/autoconf/files/autoconf-2.58-infopage-namechange.patch
deleted file mode 100644
index b1ef64cd7bbf..000000000000
--- a/sys-devel/autoconf/files/autoconf-2.58-infopage-namechange.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-diff -urN autoconf-2.58/doc/Makefile.in autoconf-2.58.info/doc/Makefile.in
---- autoconf-2.58/doc/Makefile.in 2003-09-28 16:42:23.267768088 +0200
-+++ autoconf-2.58.info/doc/Makefile.in 2003-09-28 16:42:47.480087256 +0200
-@@ -44,12 +44,12 @@
- DIST_SOURCES =
- TEXINFO_TEX = $(top_srcdir)/config/texinfo.tex
- am__TEXINFO_TEX_DIR = $(top_srcdir)/config
--INFO_DEPS = autoconf.info standards.info
-+INFO_DEPS = autoconf25.info standards.info
- DVIS = autoconf.dvi standards.dvi
- PDFS = autoconf.pdf standards.pdf
- PSS = autoconf.ps standards.ps
- HTMLS = autoconf.html standards.html
--TEXINFOS = autoconf.texi standards.texi
-+TEXINFOS = autoconf25.texi standards.texi
- TEXI2PDF = $(TEXI2DVI) --pdf --batch
- DVIPS = dvips
- am__installdirs = $(DESTDIR)$(infodir)
-@@ -116,7 +116,7 @@
- TEXI2DVI = texi2dvi --batch
- TEXI2HTML = texi2html
- TEXI2HTML_FLAGS = -split_chapter
--info_TEXINFOS = autoconf.texi standards.texi
-+info_TEXINFOS = autoconf25.texi standards.texi
- autoconf_TEXINFOS = fdl.texi install.texi
- standards_TEXINFOS = make-stds.texi
-
-@@ -192,14 +192,14 @@
- .texi.html:
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) --html -I $(srcdir) \
- -o $@ $<
--autoconf.info: autoconf.texi version.texi $(autoconf_TEXINFOS)
--autoconf.dvi: autoconf.texi version.texi $(autoconf_TEXINFOS)
--autoconf.pdf: autoconf.texi version.texi $(autoconf_TEXINFOS)
--autoconf.html: autoconf.texi version.texi $(autoconf_TEXINFOS)
-+autoconf25.info: autoconf25.texi version.texi $(autoconf_TEXINFOS)
-+autoconf.dvi: autoconf25.texi version.texi $(autoconf_TEXINFOS)
-+autoconf.pdf: autoconf25.texi version.texi $(autoconf_TEXINFOS)
-+autoconf.html: autoconf25.texi version.texi $(autoconf_TEXINFOS)
- version.texi: stamp-vti
--stamp-vti: autoconf.texi $(top_srcdir)/configure
-- @(dir=.; test -f ./autoconf.texi || dir=$(srcdir); \
-- set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf.texi`; \
-+stamp-vti: autoconf25.texi $(top_srcdir)/configure
-+ @(dir=.; test -f ./autoconf25.texi || dir=$(srcdir); \
-+ set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf25.texi`; \
- echo "@set UPDATED $$1 $$2 $$3"; \
- echo "@set UPDATED-MONTH $$2 $$3"; \
- echo "@set EDITION $(VERSION)"; \
-@@ -430,8 +430,8 @@
-
- html: autoconf_1.html standards_1.html
-
--autoconf_1.html: autoconf.texi install.texi
-- $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/autoconf.texi
-+autoconf_1.html: autoconf25.texi install.texi
-+ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/autoconf25.texi
-
- standards_1.html: standards.texi make-stds.texi
- $(TEXI2HTML) $(TEXI2HTML_FLAGS) $(srcdir)/standards.texi
-diff -urN autoconf-2.58/doc/autoconf.texi autoconf-2.58.info/doc/autoconf.texi
---- autoconf-2.58/doc/autoconf.texi 2003-09-28 16:42:23.283765656 +0200
-+++ autoconf-2.58.info/doc/autoconf.texi 2003-09-28 16:43:17.728488800 +0200
-@@ -1,9 +1,9 @@
- \input texinfo @c -*-texinfo-*-
- @comment ========================================================
- @comment %**start of header
--@setfilename autoconf.info
-+@setfilename autoconf25.info
- @include version.texi
--@settitle Autoconf
-+@settitle Autoconf v2.5
- @setchapternewpage odd
- @setcontentsaftertitlepage
- @finalout
-@@ -210,27 +210,27 @@
-
- @dircategory Software development
- @direntry
--* Autoconf: (autoconf). Create source code configuration scripts.
-+* Autoconf v2.5: (autoconf25). Create source code configuration scripts.
- @end direntry
-
- @dircategory Individual utilities
- @direntry
--* autoscan: (autoconf)autoscan Invocation.
-+* autoscan v2.5: (autoconf25)autoscan Invocation.
- Semi-automatic @file{configure.ac} writing
--* ifnames: (autoconf)ifnames Invocation. Listing conditionals in source.
--* autoconf: (autoconf)autoconf Invocation.
-+* ifnames v2.5: (autoconf25)ifnames Invocation. Listing conditionals in source.
-+* autoconf v2.5: (autoconf25)autoconf Invocation.
- How to create configuration scripts
--* autoreconf: (autoconf)autoreconf Invocation.
-+* autoreconf v2.5: (autoconf25)autoreconf Invocation.
- Remaking multiple @command{configure} scripts
--* autoheader: (autoconf)autoheader Invocation.
-+* autoheader v2.5: (autoconf25)autoheader Invocation.
- How to create configuration templates
--* autom4te: (autoconf)autom4te Invocation.
-+* autom4te v2.5: (autoconf25)autom4te Invocation.
- The Autoconf executables backbone
--* configure: (autoconf)configure Invocation. Configuring a package.
--* autoupdate: (autoconf)autoupdate Invocation.
-+* configure v2.5: (autoconf25)configure Invocation. Configuring a package.
-+* autoupdate v2.5: (autoconf25)autoupdate Invocation.
- Automatic update of @file{configure.ac}
--* config.status: (autoconf)config.status Invocation. Recreating configurations.
--* testsuite: (autoconf)testsuite Invocation. Running an Autotest test suite.
-+* config.status v2.5: (autoconf25)config.status Invocation. Recreating configurations.
-+* testsuite v2.5: (autoconf25)testsuite Invocation. Running an Autotest test suite.
- @end direntry
-
- @titlepage
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.59-r5 b/sys-devel/autoconf/files/digest-autoconf-2.59-r5
deleted file mode 100644
index a9ae401381fd..000000000000
--- a/sys-devel/autoconf/files/digest-autoconf-2.59-r5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 1ee40f7a676b3cfdc0e3f7cd81551b5f autoconf-2.59.tar.bz2 925073
-MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844