summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-02-20 00:12:27 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-02-20 00:12:27 +0000
commit4a2fc63fd9a24156fb17129f08be42fb777f7fce (patch)
tree07bd40109af2327ca7b3a291512a61536f3b1feb /sys-devel/autoconf/files
parentnew version (diff)
downloadhistorical-4a2fc63fd9a24156fb17129f08be42fb777f7fce.tar.gz
historical-4a2fc63fd9a24156fb17129f08be42fb777f7fce.tar.bz2
historical-4a2fc63fd9a24156fb17129f08be42fb777f7fce.zip
autom4te tweak
Diffstat (limited to 'sys-devel/autoconf/files')
-rw-r--r--sys-devel/autoconf/files/ac-wrapper.pl15
1 files changed, 8 insertions, 7 deletions
diff --git a/sys-devel/autoconf/files/ac-wrapper.pl b/sys-devel/autoconf/files/ac-wrapper.pl
index 7b9bcb71bb0f..50858025b7e9 100644
--- a/sys-devel/autoconf/files/ac-wrapper.pl
+++ b/sys-devel/autoconf/files/ac-wrapper.pl
@@ -39,13 +39,14 @@ my $binary = "$0-2.13";
my $binary_new = "$0-2.5x";
if (!$ENV{WANT_AUTOCONF_2_1}) {
- if (-x $binary_new # user may have only 2.13
- && ($ENV{WANT_AUTOCONF_2_5}
- || -r 'configure.ac'
- || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
- || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
- || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
- || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
+ if ((! -x $binary) # handle stuff like autom4te, where only 2.5x have the binary
+ || (-x $binary_new # user may have only 2.13
+ && ($ENV{WANT_AUTOCONF_2_5}
+ || -r 'configure.ac'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'))) {
$ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;
} else {