summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-04-25 21:58:41 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-04-25 21:58:41 +0000
commit776e35eb6c7ef3befeaf742143383e6d812432c0 (patch)
treeec88ce5e28838ea51697f57bb8fa1524e9caedf5 /sys-cluster/xpvm/xpvm-1.2.5-r3.ebuild
parentfixing Manifest (diff)
downloadhistorical-776e35eb6c7ef3befeaf742143383e6d812432c0.tar.gz
historical-776e35eb6c7ef3befeaf742143383e6d812432c0.tar.bz2
historical-776e35eb6c7ef3befeaf742143383e6d812432c0.zip
Update to respect PVM_ROOT, wherever it is (#47860). Also general fixups.
Diffstat (limited to 'sys-cluster/xpvm/xpvm-1.2.5-r3.ebuild')
-rw-r--r--sys-cluster/xpvm/xpvm-1.2.5-r3.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sys-cluster/xpvm/xpvm-1.2.5-r3.ebuild b/sys-cluster/xpvm/xpvm-1.2.5-r3.ebuild
new file mode 100644
index 000000000000..470f93755c07
--- /dev/null
+++ b/sys-cluster/xpvm/xpvm-1.2.5-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="XPVM: A graphical console and monitor for PVM"
+SRC_URI="http://www.netlib.org/pvm3/xpvm/XPVM.src.1.2.5.tgz"
+HOMEPAGE="http://www.csm.ornl.gov/pvm/pvm_home.html"
+IUSE=""
+
+DEPEND=">=sys-cluster/pvm-3.4.1-r1
+ dev-lang/tcl
+ dev-lang/tk"
+RDEPEND=""
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="LGPL-2"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/xpvm-1.2.5-gentoo.diff
+}
+
+src_compile() {
+ export XPVM_ROOT="${WORKDIR}/xpvm"
+
+ cd ${WORKDIR}/xpvm
+
+ if [ -z "${PVM_ROOT}" ]
+ then
+ die "PVM_ROOT variable not set. Please run env-update and source /etc/profile."
+ elif [ -z "${PVM_ARCH}" ]
+ then
+ die "PVM_ARCH variable not set. Please run env-update and source /etc/profile."
+ fi
+
+ emake xpvm || die
+}
+
+src_install() {
+ XPVM_ROOT=${PVM_ROOT}/xpvm
+
+ cd ${WORKDIR}/xpvm
+ dodir ${PVM_ROOT}/xpvm
+ dodir ${PVM_ROOT}/bin/${PVM_ARCH}
+ dodir /usr/bin
+
+ #create symlinks to xpvm binary
+ dosym ${XPVM_ROOT}/src/${PVM_ARCH}/xpvm ${PVM_ROOT}/bin/${PVM_ARCH}/xpvm
+ dosym ${XPVM_ROOT}/src/${PVM_ARCH}/xpvm /usr/bin/xpvm
+
+ #install headers and libs and binary
+ cp ${WORKDIR}/xpvm ${D}/${PVM_ROOT} -r
+
+ #environment variables:
+ touch ${T}/97xpvm
+ echo XPVM_ROOT=/usr/local/pvm3/xpvm/src >> ${T}/97xpvm
+ insinto /etc/env.d
+ doins ${T}/97xpvm
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Environment Variables have changed. Do not forget to reboot or perform"
+ ewarn "source /etc/profile before using xpvm !"
+}