summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-12 08:12:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-12 08:12:42 +0000
commit990f6eb275fa1862b1b1761919f6ae2442af0885 (patch)
treeba1f6915e3538d74dd102cd92ff157fa2f9a0474 /sys-cluster/lam-mpi
parentStable on x86. (diff)
downloadhistorical-990f6eb275fa1862b1b1761919f6ae2442af0885.tar.gz
historical-990f6eb275fa1862b1b1761919f6ae2442af0885.tar.bz2
historical-990f6eb275fa1862b1b1761919f6ae2442af0885.zip
Move where fortran_pkg_setup runs, as it is not needed for merging a binary package in pkg_setup.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-cluster/lam-mpi')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog7
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild7
2 files changed, 11 insertions, 3 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index aebdeb3abb0b..33913fa39381 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.38 2005/07/07 11:49:00 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.39 2005/07/12 08:12:42 robbat2 Exp $
+
+ 12 Jul 2005; Robin H. Johnson <robbat2@gentoo.org>
+ lam-mpi-7.1.1-r2.ebuild:
+ Move where fortran_pkg_setup runs, as it is not needed for merging a binary
+ package in pkg_setup.
07 Jul 2005; Markus Rothe <corsair@gentoo.org> lam-mpi-7.1.1-r2.ebuild:
added ~ppc64
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild
index 253b719090c2..2b65e9e7778f 100644
--- a/sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild,v 1.3 2005/07/07 11:49:00 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.1-r2.ebuild,v 1.4 2005/07/12 08:12:42 robbat2 Exp $
inherit fortran flag-o-matic
@@ -44,7 +44,7 @@ src_unpack() {
}
pkg_setup() {
- use fortran && fortran_pkg_setup
+ : # make sure fortran_pkg_setup does NOT run
}
src_compile() {
@@ -60,6 +60,9 @@ src_compile() {
use pbs && append-ldflags -L/usr/lib/pbs
if use fortran; then
+ fortran_pkg_setup
+ # this is NOT in pkg_setup as it is NOT needed for RDEPEND right away it
+ # can be installed after merging from binary, and still have things fine
myconf="${myconf} --with-fc=${FORTRANC}"
else
myconf="${myconf} --without-fc"