summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-05-11 20:49:12 +0000
committerNed Ludd <solar@gentoo.org>2004-05-11 20:49:12 +0000
commit4f96b935c0006bda08d3ab1be53aeb46912422ed (patch)
tree14b4494da7468e4239fc7161834809b8f05a6ed1 /sys-boot/syslinux/syslinux-2.09.ebuild
parentAdd Version 0.4.1. (diff)
downloadhistorical-4f96b935c0006bda08d3ab1be53aeb46912422ed.tar.gz
historical-4f96b935c0006bda08d3ab1be53aeb46912422ed.tar.bz2
historical-4f96b935c0006bda08d3ab1be53aeb46912422ed.zip
add ssp check before patching in nossp patches. This prevents breakage if your gcc knows nothing about -fstack-protector
Diffstat (limited to 'sys-boot/syslinux/syslinux-2.09.ebuild')
-rw-r--r--sys-boot/syslinux/syslinux-2.09.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-boot/syslinux/syslinux-2.09.ebuild b/sys-boot/syslinux/syslinux-2.09.ebuild
index 2ebd0aa82c4e..f71a3649749f 100644
--- a/sys-boot/syslinux/syslinux-2.09.ebuild
+++ b/sys-boot/syslinux/syslinux-2.09.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.09.ebuild,v 1.1 2004/04/29 03:53:12 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.09.ebuild,v 1.2 2004/05/11 20:49:12 solar Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
HOMEPAGE="http://syslinux.zytor.com/"
@@ -20,7 +20,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/2.06-nasm.patch
# -fstack-protector really does not play along well with any boot loader
- epatch ${FILESDIR}/${PN}-2.09-nossp.patch
+ $(gcc-getCC) -fstack-protector -S -o /dev/null -xc /dev/null >/dev/null 2>&1 && \
+ epatch ${FILESDIR}/${PN}-2.09-nossp.patch
sed -i 's:$(MAKE) -C win32 all::' Makefile
}