summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Jackson <tsunam@gentoo.org>2009-09-22 05:21:34 +0000
committerJoshua Jackson <tsunam@gentoo.org>2009-09-22 05:21:34 +0000
commitd53f12db0133f83f28f6ecb6ce01ef72f0f4d1ee (patch)
tree7be2bc1dd97fe83a92ad4bdd1ef083990a2da203 /sys-block/fio/fio-1.34.ebuild
parentstable on ppc64, bug #284911 (diff)
downloadhistorical-d53f12db0133f83f28f6ecb6ce01ef72f0f4d1ee.tar.gz
historical-d53f12db0133f83f28f6ecb6ce01ef72f0f4d1ee.tar.bz2
historical-d53f12db0133f83f28f6ecb6ce01ef72f0f4d1ee.zip
adding new fio with permission from Robin
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'sys-block/fio/fio-1.34.ebuild')
-rw-r--r--sys-block/fio/fio-1.34.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-block/fio/fio-1.34.ebuild b/sys-block/fio/fio-1.34.ebuild
new file mode 100644
index 000000000000..52e4797276f3
--- /dev/null
+++ b/sys-block/fio/fio-1.34.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-1.34.ebuild,v 1.1 2009/09/22 05:21:34 tsunam Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-flags -W
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}