summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2004-06-21 06:44:38 +0000
committerWolfram Schlich <wschlich@gentoo.org>2004-06-21 06:44:38 +0000
commited8f0094e1dcd706e64fc5805e6d8e68e9e9b408 (patch)
tree3b7f95e95d3b4751d614cc50ada7cb6b83ff1d60 /sys-apps
parentFix typo, bug #54582. (diff)
downloadhistorical-ed8f0094e1dcd706e64fc5805e6d8e68e9e9b408.tar.gz
historical-ed8f0094e1dcd706e64fc5805e6d8e68e9e9b408.tar.bz2
historical-ed8f0094e1dcd706e64fc5805e6d8e68e9e9b408.zip
version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/htop/Manifest2
-rw-r--r--sys-apps/htop/files/digest-htop-0.3.31
-rw-r--r--sys-apps/htop/htop-0.3.3.ebuild33
3 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/htop/Manifest b/sys-apps/htop/Manifest
index e8914b454338..baea6d94d10a 100644
--- a/sys-apps/htop/Manifest
+++ b/sys-apps/htop/Manifest
@@ -3,6 +3,8 @@ MD5 ce433d9edceef9e3225f605121ec61fd htop-0.3.ebuild 670
MD5 11e47e8144f38cc73b144eb2bfb41b25 ChangeLog 702
MD5 be2505c8d1d30960604fa361c0d63f34 htop-0.3.1.ebuild 778
MD5 43501f3b11f0e754837938e9bdd8bd95 htop-0.3.2.ebuild 778
+MD5 6e146071ccf5050795151e6012464634 htop-0.3.3.ebuild 778
MD5 8123f72d136ab55139efee23411e3ab6 files/digest-htop-0.3 59
MD5 47f1850a95a3c5c1447a7606ca9ff1ad files/digest-htop-0.3.1 61
MD5 334fab92d3a6331a9de56b3f52f47c88 files/digest-htop-0.3.2 61
+MD5 162b1b379ac437b9a5e4002ea69f4cb3 files/digest-htop-0.3.3 61
diff --git a/sys-apps/htop/files/digest-htop-0.3.3 b/sys-apps/htop/files/digest-htop-0.3.3
new file mode 100644
index 000000000000..17ae8f1c1fba
--- /dev/null
+++ b/sys-apps/htop/files/digest-htop-0.3.3
@@ -0,0 +1 @@
+MD5 540e135361d3619aaa1268eb15868c76 htop-0.3.3.tar.gz 91820
diff --git a/sys-apps/htop/htop-0.3.3.ebuild b/sys-apps/htop/htop-0.3.3.ebuild
new file mode 100644
index 000000000000..a24516977039
--- /dev/null
+++ b/sys-apps/htop/htop-0.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/htop-0.3.3.ebuild,v 1.1 2004/06/21 06:44:38 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug"
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}