summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-01 06:51:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-01 06:51:10 +0000
commitc80755405548a8b15d23e02aeb6d9a63cf76e3fb (patch)
tree5e8be247ecf73b85755a8f4c7d2f2b80dff8f67d /sys-apps
parentremove all old php ebuilds before 4.3.4-r4. (diff)
downloadhistorical-c80755405548a8b15d23e02aeb6d9a63cf76e3fb.tar.gz
historical-c80755405548a8b15d23e02aeb6d9a63cf76e3fb.tar.bz2
historical-c80755405548a8b15d23e02aeb6d9a63cf76e3fb.zip
touchups
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index 558c00a80f25..45a0df3f9899 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,49 +1,42 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.4 2004/03/02 16:11:38 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.5 2004/04/01 06:51:10 vapier Exp $
+
+inherit gnuconfig
DESCRIPTION="Super-useful stream editor"
-SRC_URI="mirror://gnu/sed/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/sed/sed.html"
+SRC_URI="mirror://gnu/sed/${P}.tar.gz"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~ppc64 s390"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~ppc64 s390"
IUSE="nls static build"
-inherit gnuconfig
-
DEPEND="virtual/glibc
nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
-
# Allow sed to detect mips systems properly
use mips && gnuconfig_update
- use nls \
- && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- econf ${myconf} || die "Configure failed"
- if [ -z `use static` ] ; then
- emake || die "Shared build failed"
- else
+ econf `use_enable nls` || die "Configure failed"
+ if use static ; then
emake LDFLAGS=-static || die "Static build failed"
+ else
+ emake || die "Shared build failed"
fi
}
src_install() {
into /
dobin sed/sed
- if [ -z "`use build`" ]
+ if ! use build
then
einstall || die "Install failed"
dodoc COPYING NEWS README* THANKS AUTHORS BUGS ChangeLog
docinto examples
dodoc ${FILESDIR}/dos2unix ${FILESDIR}/unix2dos
-
else
dodir /usr/bin
fi