summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2004-04-01 18:13:58 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2004-04-01 18:13:58 +0000
commitc0ec2321204ef5ec44c6ccd3a56e8292ffe22fef (patch)
tree81de427511d6d6d609c0058f3b28711b11b29730 /sys-apps
parentFixed compilation failure with gtk+ 2.4. Thanks to ikezoe <ikezoe@users.sourc... (diff)
downloadhistorical-c0ec2321204ef5ec44c6ccd3a56e8292ffe22fef.tar.gz
historical-c0ec2321204ef5ec44c6ccd3a56e8292ffe22fef.tar.bz2
historical-c0ec2321204ef5ec44c6ccd3a56e8292ffe22fef.zip
2004_04_01 version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hotplug/ChangeLog11
-rw-r--r--sys-apps/hotplug/Manifest4
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-200404011
-rw-r--r--sys-apps/hotplug/hotplug-20040401.ebuild57
4 files changed, 71 insertions, 2 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index a0cda04ff11f..07a2006e519a 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.36 2004/03/30 01:11:28 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.37 2004/04/01 18:13:58 gregkh Exp $
+
+*hotplug-20040401 (01 Apr 2004)
+
+ 01 Apr 2004; Greg Kroah-Hartman <gregkh@gentoo.org> hotplug-20040401.ebuild:
+ 2004_04_01 version bump, which includes all Gentoo specific patches are
+ now pushed into the upstream package, making my life a whole lot easier :)
+
+ This fixes a number of usb and network hotplug bugs with the previous
+ hotplug package.
29 Mar 2004; Greg Kroah-Hartman <gregkh@gentoo.org> files/hotplug.rc:
Change the hotplug init.d script to show what subsystem it is starting
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index ab7f00166477..bb656976f443 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,4 +1,4 @@
-MD5 40952953231923739fe7671420f36c32 ChangeLog 6145
+MD5 8687bf5a4c8f5516d8ff75c9aa3b8081 ChangeLog 6503
MD5 20c3f8b015678d0bf9d6463fef97dcd7 hotplug-20020826-r2.ebuild 1561
MD5 b0a484d63057d74095ddeb36f7700ce6 hotplug-20030501-r2.ebuild 1515
MD5 da047afd1a129c6f8ace01cd8627e401 hotplug-20030805-r1.ebuild 1743
@@ -9,6 +9,7 @@ MD5 62ab73984a19639323de44c2e9ea3d21 hotplug-20040105.ebuild 1720
MD5 6dd0dae507894daeb8b368e45a33c630 hotplug-20040311.ebuild 1691
MD5 075d5a933d6175160a02ddf15bd4f454 metadata.xml 260
MD5 1b5433c5d911423a4395114a4564222c hotplug-20040329.ebuild 1576
+MD5 b1416059e5f11d2ba2bb1b7e04a356df hotplug-20040401.ebuild 1514
MD5 0e5a1a005fcfa0e242be02e9ef99de7a files/digest-hotplug-20020826-r2 224
MD5 40927deb2fb37aa51529d46a9b55e051 files/digest-hotplug-20030501-r2 154
MD5 a3281f5b866be688f79d9a46d060180a files/digest-hotplug-20030805 151
@@ -24,3 +25,4 @@ MD5 9f13f3363b85caac03bfb623c652b4fa files/kernel-26-fix.patch 816
MD5 92547b2263d5423d874565504d2324f7 files/usb.agent.diff 886
MD5 1bd9ddb0959318fe56dec239c8265fb1 files/usb.confd 291
MD5 cdf598564a6f23642c5a1c9518432670 files/digest-hotplug-20040329 69
+MD5 5be3a96d844a1f0db96e2268b94f6094 files/digest-hotplug-20040401 69
diff --git a/sys-apps/hotplug/files/digest-hotplug-20040401 b/sys-apps/hotplug/files/digest-hotplug-20040401
new file mode 100644
index 000000000000..d910ec23412b
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20040401
@@ -0,0 +1 @@
+MD5 d677a75d6dd6cabbb929470418ad8018 hotplug-2004_04_01.tar.gz 41287
diff --git a/sys-apps/hotplug/hotplug-20040401.ebuild b/sys-apps/hotplug/hotplug-20040401.ebuild
new file mode 100644
index 000000000000..ac9c5ce944c5
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20040401.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20040401.ebuild,v 1.1 2004/04/01 18:13:58 gregkh Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9 >=sys-apps/usbutils-0.9 hotplug-base"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patches go here if needed...
+}
+
+src_install() {
+ into /
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc *.permissions
+ dodir /usr/lib/hotplug/firmware
+ dodir /etc/hotplug/usb
+ dodir /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
+