summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-07-10 20:09:37 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-07-10 20:09:37 +0000
commit8644ef9669e80e95b4ad163bb0b1da43f153dca0 (patch)
treebb0838c348493bc7b3a823f0b491556b2949cc71 /sys-apps
parentBump (diff)
downloadhistorical-8644ef9669e80e95b4ad163bb0b1da43f153dca0.tar.gz
historical-8644ef9669e80e95b4ad163bb0b1da43f153dca0.tar.bz2
historical-8644ef9669e80e95b4ad163bb0b1da43f153dca0.zip
Bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gawk/Manifest4
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.31
-rw-r--r--sys-apps/gawk/gawk-3.1.3.ebuild112
3 files changed, 115 insertions, 2 deletions
diff --git a/sys-apps/gawk/Manifest b/sys-apps/gawk/Manifest
index a46d5d8440de..62a70c5921cb 100644
--- a/sys-apps/gawk/Manifest
+++ b/sys-apps/gawk/Manifest
@@ -1,7 +1,7 @@
MD5 9257e56533594eb3442dfcad177ec030 gawk-3.1.2-r3.ebuild 2948
-MD5 bf662a2856550a6953379fe04aac38e3 ChangeLog 5145
+MD5 62491cb1adb451b43766e8a3b19a303e ChangeLog 5252
MD5 1de7b808b29f35ae776744e356e29b07 gawk-3.1.1-r2.ebuild 2434
-MD5 7cf88e17a2c377284ed71b62c5d9bbd0 gawk-3.1.3.ebuild 2961
+MD5 9bc9cc39f8292ef601508130f42345f5 gawk-3.1.3.ebuild 2575
MD5 9f439b073b0d1903a54a04dca5aa44af files/gawk-3.1.2-input-filesize.patch 13485
MD5 9ee5f35f388bc0943f9f1df199bdd64d files/digest-gawk-3.1.1-r2 63
MD5 0a6cc5ae974c8876f6c3e975d7fb95e3 files/digest-gawk-3.1.2-r3 63
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.3 b/sys-apps/gawk/files/digest-gawk-3.1.3
new file mode 100644
index 000000000000..0bb5d217017a
--- /dev/null
+++ b/sys-apps/gawk/files/digest-gawk-3.1.3
@@ -0,0 +1 @@
+MD5 b637b454005f9e72a9a8eecfacd07ca0 gawk-3.1.3.tar.gz 2078246
diff --git a/sys-apps/gawk/gawk-3.1.3.ebuild b/sys-apps/gawk/gawk-3.1.3.ebuild
new file mode 100644
index 000000000000..878d470e253d
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.1.3.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.3.ebuild,v 1.1 2003/07/10 20:09:30 lostlogic Exp $
+
+IUSE="nls build"
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="GNU awk pattern-matching language"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gawk/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Copy filefuncs module's source over ...
+ cp -a ${FILESDIR}/filefuncs ${WORKDIR}/ || die
+
+ cd ${S}
+ # support for dec compiler.
+ [ "${CC}" == "ccc" ] && epatch ${FILESDIR}/${PN}-3.1.2-dec-alpha-compiler.diff
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+
+ einfo "Building gawk ..."
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/awk \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+
+ einfo "Building filefuncs module ..."
+ cd ${WORKDIR}/filefuncs
+ make AWKINCDIR=${S} || die
+}
+
+src_install() {
+ einfo "Installing gawk ..."
+ make prefix=${D}/usr \
+ bindir=${D}/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ libexecdir=${D}/usr/lib/awk \
+ install || die
+
+ einfo "Installing filefuncs module ..."
+ cd ${WORKDIR}/filefuncs
+ make DESTDIR=${D} \
+ AWKINCDIR=${S} \
+ install || die
+
+ # In some rare cases, gawk gets installed as gawk- and not gawk-${PV} ..
+ if [ -f ${D}/bin/gawk -a ! -f ${D}/bin/gawk-${PV} ]
+ then
+ mv -f ${D}/bin/gawk ${D}/bin/gawk-${PV}
+ elif [ -f ${D}/bin/gawk- -a ! -f ${D}/bin/gawk-${PV} ]
+ then
+ mv -f ${D}/bin/gawk ${D}/bin/gawk-${PV}
+ fi
+
+ rm -f ${D}/bin/{awk,gawk}
+ dosym gawk-${PV} /bin/awk
+ dosym gawk-${PV} /bin/gawk
+ #compat symlink
+ dodir /usr/bin
+ dosym ../../bin/gawk-${PV} /usr/bin/awk
+ dosym ../../bin/gawk-${PV} /usr/bin/gawk
+
+ # Install headers
+ insinto /usr/include/awk
+ for x in ${S}/*.h
+ do
+ # We do not want 'acconfig.h' in there ...
+ if [ -f "${x}" -a "${x/acconfig\.h/}" = "${x}" ]
+ then
+ doins ${x}
+ fi
+ done
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ dodoc AUTHORS ChangeLog COPYING FUTURES
+ dodoc LIMITATIONS NEWS PROBLEMS POSIX.STD README
+ docinto README_d
+ dodoc README_d/*
+ docinto awklib
+ dodoc awklib/ChangeLog
+ docinto pc
+ dodoc pc/ChangeLog
+ docinto posix
+ dodoc posix/ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+