summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-18 01:57:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-18 01:57:38 +0000
commit650273867901f62a179ab3455c349e7f2d188450 (patch)
treedcbd8a6ea77cd352c19d18d82fbc46f207a783ed /sys-apps
parentadd ~arm (diff)
downloadhistorical-650273867901f62a179ab3455c349e7f2d188450.tar.gz
historical-650273867901f62a179ab3455c349e7f2d188450.tar.bz2
historical-650273867901f62a179ab3455c349e7f2d188450.zip
version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/utempter/ChangeLog8
-rw-r--r--sys-apps/utempter/Manifest6
-rw-r--r--sys-apps/utempter/files/digest-utempter-0.5.3.21
-rw-r--r--sys-apps/utempter/utempter-0.5.2.ebuild4
-rw-r--r--sys-apps/utempter/utempter-0.5.3.2.ebuild50
5 files changed, 64 insertions, 5 deletions
diff --git a/sys-apps/utempter/ChangeLog b/sys-apps/utempter/ChangeLog
index 635b89f8b826..cd27e8e9ebb5 100644
--- a/sys-apps/utempter/ChangeLog
+++ b/sys-apps/utempter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/utempter
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.5 2003/10/19 00:33:36 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.6 2004/01/18 01:57:38 seemant Exp $
+
+*utempter-0.5.3.2 (17 Jan 2004)
+
+ 17 Jan 2004; Seemant Kulleen <seemant@gentoo.org> utempter-0.5.3.2.ebuild :
+
+ Using the rpm eclass for this version.
19 Oct 2003; Sven Blumenstein <bazik@gentoo.org> utempter-0.5.2.ebuild:
Added sparc keyword.
diff --git a/sys-apps/utempter/Manifest b/sys-apps/utempter/Manifest
index 649d40c9709b..0326a1bd1f4c 100644
--- a/sys-apps/utempter/Manifest
+++ b/sys-apps/utempter/Manifest
@@ -1,4 +1,6 @@
-MD5 3a9138e8b498fa77a68b1ba354a831fc utempter-0.5.2.ebuild 741
-MD5 44d78a69103fc3b749fe82cc41307fe4 ChangeLog 881
+MD5 de194bc332792e55cb422d43244f5f5c utempter-0.5.2.ebuild 741
+MD5 a52371f69fbbf968c8b333a58613a0fe ChangeLog 1037
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 da1a3a4c65400eb93a6ed897cf466ea5 utempter-0.5.3.2.ebuild 1131
+MD5 33c9a8bf7fd33ad52e6fe296e35543d4 files/digest-utempter-0.5.3.2 68
MD5 a5f81a801233fc1c8464078fa452836a files/digest-utempter-0.5.2 65
diff --git a/sys-apps/utempter/files/digest-utempter-0.5.3.2 b/sys-apps/utempter/files/digest-utempter-0.5.3.2
new file mode 100644
index 000000000000..de29205476b8
--- /dev/null
+++ b/sys-apps/utempter/files/digest-utempter-0.5.3.2
@@ -0,0 +1 @@
+MD5 5d664e65249161a92400b5d442a2a159 utempter-0.5.3-2.src.rpm 19395
diff --git a/sys-apps/utempter/utempter-0.5.2.ebuild b/sys-apps/utempter/utempter-0.5.2.ebuild
index 48efc7c51cc4..f4d9ec644b51 100644
--- a/sys-apps/utempter/utempter-0.5.2.ebuild
+++ b/sys-apps/utempter/utempter-0.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.2.ebuild,v 1.8 2004/01/18 00:56:37 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.2.ebuild,v 1.9 2004/01/18 01:57:38 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="App that allows non-privileged apps to write utmp (login) info, which needs root access"
diff --git a/sys-apps/utempter/utempter-0.5.3.2.ebuild b/sys-apps/utempter/utempter-0.5.3.2.ebuild
new file mode 100644
index 000000000000..8f8cf3ddd722
--- /dev/null
+++ b/sys-apps/utempter/utempter-0.5.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.3.2.ebuild,v 1.1 2004/01/18 01:57:38 seemant Exp $
+
+inherit rpm eutils
+
+MY_P=${P%.*}-${PV##*.}
+S=${WORKDIR}/${P%.*}
+DESCRIPTION="App that allows non-privileged apps to write utmp (login) info, which needs root access"
+# no homepage really, but redhat are the authors
+HOMEPAGE="http://www.redhat.com"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/1/SRPMS/${MY_P}.src.rpm"
+
+SLOT="0"
+LICENSE="MIT | LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64 ~ppc64"
+
+RDEPEND="virtual/glibc"
+
+pkg_setup() {
+ enewgroup utmp 406
+}
+
+src_compile() {
+ make RPM_OPT_FLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ make RPM_BUILD_ROOT="${D}" install
+ dobin utmp
+ dodoc COPYING
+}
+
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ if [ -f /var/log/wtmp ]
+ then
+ chown root:utmp /var/log/wtmp
+ chmod 664 /var/log/wtmp
+ fi
+
+ if [ -f /var/run/utmp ]
+ then
+ chown root:utmp /var/run/utmp
+ chmod 664 /var/run/utmp
+ fi
+ fi
+}