summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Blaabjerg <styx@gentoo.org>2002-08-13 12:48:33 +0000
committerJoachim Blaabjerg <styx@gentoo.org>2002-08-13 12:48:33 +0000
commit4d7514f2f4c8410457985a74a122580c0ae44e01 (patch)
tree14d64cd2b1dffd9f2667b2dae92b30ca911e8476 /sys-apps/tcb
parentfix 3.1beta1 download urls (diff)
downloadhistorical-4d7514f2f4c8410457985a74a122580c0ae44e01.tar.gz
historical-4d7514f2f4c8410457985a74a122580c0ae44e01.tar.bz2
historical-4d7514f2f4c8410457985a74a122580c0ae44e01.zip
New ebuild: sys-apps/tcb; first ebuild for the secure profile
Diffstat (limited to 'sys-apps/tcb')
-rw-r--r--sys-apps/tcb/ChangeLog10
-rw-r--r--sys-apps/tcb/files/digest-tcb-0.9.7.41
-rw-r--r--sys-apps/tcb/tcb-0.9.7.4.ebuild34
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/tcb/ChangeLog b/sys-apps/tcb/ChangeLog
new file mode 100644
index 000000000000..cca7ed8ad3e5
--- /dev/null
+++ b/sys-apps/tcb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/tcb
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*tcb-0.9.7.4 (13 Aug 2002)
+
+ 13 Aug 2002; Joachim Blaabjerg <styx@gentoo.org> tcb-0.9.7.4.ebuild :
+
+ Initial ebuild release. Wrote this on 19 Apr 2002, but didn't get it
+ committed until now. Talk about lazyness :P
diff --git a/sys-apps/tcb/files/digest-tcb-0.9.7.4 b/sys-apps/tcb/files/digest-tcb-0.9.7.4
new file mode 100644
index 000000000000..c2831cf253d0
--- /dev/null
+++ b/sys-apps/tcb/files/digest-tcb-0.9.7.4
@@ -0,0 +1 @@
+MD5 d3cf3796b92df2d7857441894245e776 tcb-0.9.7.4.tar.bz2 30319
diff --git a/sys-apps/tcb/tcb-0.9.7.4.ebuild b/sys-apps/tcb/tcb-0.9.7.4.ebuild
new file mode 100644
index 000000000000..ff1e0f048c46
--- /dev/null
+++ b/sys-apps/tcb/tcb-0.9.7.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme."
+# This is a bad solution, but the original source archive is in the Owl cvs
+SRC_URI="http://www.SuxOS.org/~styx/gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.openwall.com"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/pam-0.75"
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="x86"
+
+pkg_preinst() {
+ # might want to add these into baselayout eventually...
+ for group in auth chkpwd shadow; do
+ if ! grep -q ^${group}: /etc/group ; then
+ groupadd ${group} || die "problem adding group $group"
+ fi
+ done
+}
+
+src_compile() {
+# cd ${WORKDIR}
+ emake || die
+}
+
+src_install () {
+ make FAKEROOT=${D} install || die
+ dodoc ChangeLog LICENSE
+}