summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-31 16:05:09 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-31 16:05:09 +0000
commitc7fc07db736366739206898027b1326d826082f4 (patch)
tree12bdf79a56a569421b8f1bb22c7b6ca401b777e2 /sys-apps/pciutils
parentppc64 stable wrt #384221 (diff)
downloadhistorical-c7fc07db736366739206898027b1326d826082f4.tar.gz
historical-c7fc07db736366739206898027b1326d826082f4.tar.bz2
historical-c7fc07db736366739206898027b1326d826082f4.zip
Split logic between supporting a compressed db (USE=zlib) and using one (USE=compress-db) #360849 #397591 and some others.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog9
-rw-r--r--sys-apps/pciutils/metadata.xml6
-rw-r--r--sys-apps/pciutils/pciutils-3.1.9-r1.ebuild76
3 files changed, 87 insertions, 4 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 1d45fde792f6..a3af836a906f 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.186 2012/01/20 05:13:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.187 2012/01/31 16:05:09 vapier Exp $
+
+*pciutils-3.1.9-r1 (31 Jan 2012)
+
+ 31 Jan 2012; Mike Frysinger <vapier@gentoo.org> +pciutils-3.1.9-r1.ebuild,
+ metadata.xml:
+ Split logic between supporting a compressed db (USE=zlib) and using one
+ (USE=compress-db) #360849 #397591 and some others.
*pciutils-3.1.9 (20 Jan 2012)
diff --git a/sys-apps/pciutils/metadata.xml b/sys-apps/pciutils/metadata.xml
index 4902280d842d..ac8266dbf250 100644
--- a/sys-apps/pciutils/metadata.xml
+++ b/sys-apps/pciutils/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>base-system</herd>
<use>
- <flag name='network-cron'>
- Monthly cronjob the update-pciids script
- </flag>
+ <flag name='compress-db'>Compress pci.ids database by default</flag>
+ <flag name='network-cron'>Monthly cronjob the update-pciids script</flag>
+ <flag name='zlib'>Support compressed pci.ids database</flag>
</use>
</pkgmetadata>
diff --git a/sys-apps/pciutils/pciutils-3.1.9-r1.ebuild b/sys-apps/pciutils/pciutils-3.1.9-r1.ebuild
new file mode 100644
index 000000000000..e53145d5f7db
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.1.9-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.1.9-r1.ebuild,v 1.1 2012/01/31 16:05:09 vapier Exp $
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="compress-db network-cron static-libs zlib"
+REQUIRED_USE="compress-db? ( zlib )"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.7-install-lib.patch #273489
+ epatch "${FILESDIR}"/${PN}-3.1.7-fbsd.patch #262321
+
+ if use static-libs ; then
+ cp -pPR "${S}" "${S}.static" || die
+ fi
+}
+
+pemake() {
+ emake \
+ HOST="${CHOST}" \
+ CROSS_COMPILE="${CHOST}-" \
+ CC="$(tc-getCC)" \
+ DNS="yes" \
+ IDSDIR='$(SHAREDIR)/misc' \
+ MANDIR='$(SHAREDIR)/man' \
+ PREFIX="${EPREFIX}/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(usex zlib) \
+ PCI_COMPRESSED_IDS=$(usex compress-db 1 0) \
+ PCI_IDS=$(usex compress-db pci.ids{.gz,}) \
+ LIBDIR="\${PREFIX}/$(get_libdir)" \
+ "$@"
+}
+
+src_compile() {
+ pemake OPT="${CFLAGS}" all
+ if use static-libs ; then
+ pemake \
+ -C "${S}.static" \
+ OPT="${CFLAGS}" \
+ SHARED="no" \
+ lib/libpci.a
+ fi
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install install-lib
+ use static-libs && dolib.a "${S}.static/lib/libpci.a"
+ dodoc ChangeLog README TODO
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids
+ fi
+
+ newinitd "${FILESDIR}"/init.d-pciparm pciparm
+ newconfd "${FILESDIR}"/conf.d-pciparm pciparm
+}
+
+pkg_postinst() {
+ elog "The 'pcimodules' program has been replaced by 'lspci -k'"
+}