summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-12-09 23:31:47 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-12-09 23:31:47 +0000
commitc96d42f72590332b71760beb38a1e46a4c41cbd3 (patch)
tree6fa10554dfd00b28e095a95c805171790b85921d /sys-apps/module-init-tools
parentVersion bump; closes bug #35396. (diff)
downloadhistorical-c96d42f72590332b71760beb38a1e46a4c41cbd3.tar.gz
historical-c96d42f72590332b71760beb38a1e46a4c41cbd3.tar.bz2
historical-c96d42f72590332b71760beb38a1e46a4c41cbd3.zip
Version bump; closes bug #35396.
Diffstat (limited to 'sys-apps/module-init-tools')
-rw-r--r--sys-apps/module-init-tools/Manifest4
-rw-r--r--sys-apps/module-init-tools/files/digest-module-init-tools-0.9.15_pre42
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.15_pre4.ebuild163
3 files changed, 167 insertions, 2 deletions
diff --git a/sys-apps/module-init-tools/Manifest b/sys-apps/module-init-tools/Manifest
index d4e3d939061e..93eef53d18bd 100644
--- a/sys-apps/module-init-tools/Manifest
+++ b/sys-apps/module-init-tools/Manifest
@@ -1,9 +1,9 @@
MD5 7c7bc0686633525168414a46cc48ac56 module-init-tools-0.9.14.ebuild 4620
-MD5 8ad6c89b94ec606f7fb24c31bb4e14ea ChangeLog 9742
+MD5 8b858f0a7adac61b51dd1a918be045e1 ChangeLog 9742
MD5 84fd34c0fab48ffc68a7ab6cad0b1d7f module-init-tools-0.9.15_pre1.ebuild 4344
MD5 3d429ef95481c4593ffc66dac26fbb13 module-init-tools-0.9.12-r1.ebuild 4818
MD5 45e1e804448b6be2c8ab49a7bb7f9f76 module-init-tools-0.9.13_pre2.ebuild 4727
-MD5 2eabb8ac8f908742879fb4788409657d module-init-tools-0.9.15_pre4.ebuild 4336
+MD5 4e3a0a30a01227e869696b129dbdf416 module-init-tools-0.9.15_pre4.ebuild 4465
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 b048068fbd625ad11940c6069a3794bc module-init-tools-0.9.15_pre3.ebuild 4464
MD5 750347b3ed077e7af344b8f89fddcea1 module-init-tools-0.9.15_pre2.ebuild 4431
diff --git a/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.15_pre4 b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.15_pre4
new file mode 100644
index 000000000000..790dd6c33784
--- /dev/null
+++ b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.15_pre4
@@ -0,0 +1,2 @@
+MD5 926ab7ad26ea3d991885d37f124427ea module-init-tools-0.9.15-pre4.tar.bz2 118107
+MD5 704c8d2834bcaa6f31d4ad79d154157a modutils-2.4.26.tar.bz2 235135
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.15_pre4.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.15_pre4.ebuild
new file mode 100644
index 000000000000..11b1c2b05cc7
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-0.9.15_pre4.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.15_pre4.ebuild,v 1.1 2003/12/09 23:31:40 plasmaroo Exp $
+
+# This ebuild includes backwards compatability for stable 2.4 kernels
+IUSE=""
+
+inherit flag-o-matic eutils gnuconfig
+
+MYP="${P/_pre/-pre}"
+S="${WORKDIR}/${MYP}"
+MODUTILS_PV="2.4.26"
+DESCRIPTION="Kernel module tools for the development kernel >=2.5.48"
+SRC_URI="mirror://kernel/linux/kernel/people/rusty/modules/${MYP}.tar.bz2
+ mirror://kernel/linux/kernel/people/rusty/modules/old/${MYP}.tar.bz2
+ mirror://kernel/linux/utils/kernel/modutils/v2.4/modutils-${MODUTILS_PV}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/rusty/modules"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~arm ~ia64"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+PROVIDE="virtual/modutils"
+
+src_unpack() {
+ unpack ${A}
+
+ # With the b0rked modutils, "modprobe hid" does work. But if something
+ # (like hotplug) tries to auto-load hid (because another module needs it,
+ # via the kernel module auto-loader) and keybdev.o or mousedev.o don't
+ # exist, then the "above" clause fails and the hid module never gets
+ # loaded, and then things like USB will fail. Thus we remove it all
+ # together.
+ #
+ # <drobbins@gentoo.org> (26 Mar 2003)
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ epatch ${FILESDIR}/modutils-2.4.22-no-above-below.patch
+
+ # Support legacy .o modules
+ cd ${S}; epatch ${FILESDIR}/${PN}-0.9.15-legacy-modext-support.patch
+
+ cd ${S}
+ rm -f missing
+ automake --add-missing
+}
+
+src_compile() {
+
+ # If running mips64, we need updated configure data
+ use mips && gnuconfig_update
+
+ local myconf=
+
+ filter-flags -fPIC
+
+ einfo "Building modutils..."
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+
+ econf \
+ --disable-strip \
+ --prefix=/ \
+ --disable-insmod-static \
+ --disable-zlib \
+ ${myconf}
+
+ emake || die "emake modutils failed"
+ einfo "Building module-init-tools..."
+ cd ${S}
+
+ econf \
+ --prefix=/ \
+ --enable-zlib \
+ ${myconf}
+
+ emake || die "emake module-init-tools failed"
+}
+
+src_install () {
+
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ einstall prefix="${D}"
+
+ docinto modutils-${MODUTILS_PV}
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+
+ cd ${S}
+ # This copies the old version of modutils to *.old so it still works
+ # with kernels <= 2.4; new versions will execve() the .old version if
+ # a 2.4 kernel is running...
+ # This code was borrowed from the module-init-tools Makefile
+ local runme=
+ local f=
+ for f in lsmod modprobe rmmod depmod insmod modinfo
+ do
+ if [ -L ${D}/sbin/${f} ]
+ then
+ einfo "Moving symlink $f to ${f}.old"
+ #runme = the target of the symlink with a .old tagged on.
+ runme="`ls -l ${D}/sbin/${f} | sed 's/.* -> //'`.old"
+ [ ! -e ${D}/sbin/${runme} ] || einfo "${D}/sbin/${runme} not found"
+ dosym $runme /sbin/${f} || die
+ elif [ -e ${D}/sbin/${f} ]
+ then
+ einfo "Moving executable $f to ${f}.old"
+ fi
+ mv -f ${D}/sbin/${f} ${D}/sbin/${f}.old
+ done
+ # Move the man pages as well. We only do this for the man pages of the
+ # tools that module-init-tools will replace.
+ for f in ${D}/usr/share/man/man8/{lsmod,modprobe,rmmod,depmod,insmod}.8
+ do
+ mv -f ${f} ${f%\.*}.old.${f##*\.}
+ done
+
+ einstall prefix=${D}
+
+ # Install compat symlink
+ dosym ../bin/lsmod /sbin/lsmod
+ dosym ../sbin/insmod.old /bin/lsmod.old
+ # Install the modules.conf2modprobe.conf tool, so we can update
+ # modprobe.conf.
+ into /
+ dosbin ${S}/generate-modprobe.conf
+ # Create the new modprobe.conf
+ dodir /etc
+ rm -f ${D}/etc/modprobe.conf
+ if [ ! -f ${ROOT}/etc/modprobe.devfs ]
+ then
+ # Support file for the devfs hack .. needed else modprobe borks.
+ # Baselayout-1.8.6.3 or there abouts will have a modules-update that
+ # will correctly generate /etc/modprobe.devfs ....
+ echo "### This file is automatically generated by modules-update" \
+ > ${D}/etc/modprobe.devfs
+ else
+ # This is dynamic, so we do not want this in the package ...
+ rm -f ${D}/etc/modprobe.devfs
+ fi
+
+ doman *.[1-8]
+ docinto /
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ einfo "Updating config files..."
+ if [ -x /sbin/modules-update ]
+ then
+ /sbin/modules-update
+ elif [ -x /sbin/update-modules ]
+ then
+ /sbin/update-modules
+ elif [ -x /usr/sbin/update-modules ]
+ then
+ /usr/sbin/update-modules
+ fi
+ fi
+}
+