summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-19 09:40:37 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-19 09:40:37 +0000
commitc82949ec968952a70acb892622653b69fc2823a1 (patch)
treea37800f8d5c5f62f3c6c77aa572b0e2f08600b85 /sys-apps/module-init-tools
parentmoved to stable (diff)
downloadhistorical-c82949ec968952a70acb892622653b69fc2823a1.tar.gz
historical-c82949ec968952a70acb892622653b69fc2823a1.tar.bz2
historical-c82949ec968952a70acb892622653b69fc2823a1.zip
bump and ebuild fixage
Diffstat (limited to 'sys-apps/module-init-tools')
-rw-r--r--sys-apps/module-init-tools/ChangeLog12
-rw-r--r--sys-apps/module-init-tools/files/digest-module-init-tools-0.9.42
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.4.ebuild96
3 files changed, 109 insertions, 1 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index 775db72bb669..5f092af65489 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.2 2002/12/11 08:11:35 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.3 2002/12/19 09:40:37 lostlogic Exp $
+
+*module-init-tools-0.9.4 (19 Dec 2002)
+
+ 19 Dec 2002; Brandon Low <lostlogic@gentoo.org> module-init-tools-0.9.4 :
+
+ Changes as submitted by Tony Murray <murrant@bvu.edu>:
+ added modules.conf2modprobe.conf tool
+ made warning after emerge visible
+ added IUSE
+ fixed spacing
*module-init-tools-0.9.3 (11 Dec 2002)
diff --git a/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.4 b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.4
new file mode 100644
index 000000000000..4fdf2a2ffc40
--- /dev/null
+++ b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.4
@@ -0,0 +1,2 @@
+MD5 9ee8c79252b5640ebb6733b0bfeb7431 module-init-tools-0.9.4.tar.bz2 78664
+MD5 6c5d2a62ae98708f3ad0c57900d63919 modutils-2.4.22.tar.bz2 219457
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.4.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.4.ebuild
new file mode 100644
index 000000000000..9c19c6c4f766
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-0.9.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.4.ebuild,v 1.1 2002/12/19 09:40:37 lostlogic Exp $
+
+# This includes backwards compatability for stable kernels
+
+S="${WORKDIR}/${P}"
+MODUTILS_PV=2.4.22
+DESCRIPTION="Kernel module tools for the development kernel >=2.5.48"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/rusty/modules/${P}.tar.bz2
+ http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/modutils-${MODUTILS_PV}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/rusty/modules"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-kernel/development-sources-2.5.48"
+
+src_compile() {
+ einfo "Building modutils..."
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+
+ econf \
+ --disable-strip \
+ --prefix=/ \
+ --enable-insmod-static \
+ --disable-zlib \
+ ${myconf}
+ emake || die "emake modultils failed"
+
+ einfo "Building module-init-tools..."
+ cd ${S}
+
+ econf \
+ --prefix=/ \
+ ${myconf}
+
+ emake || die "emake module-init-tools failed"
+}
+
+src_install () {
+
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ einstall prefix="${D}"
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+
+ cd ${S}
+ #this copies the old version of modutils to *.old so it still works
+ #with kernels <= 2.4
+ #This code was borrowed from the module-init-tools Makefile
+ for f in lsmod modprobe rmmod depmod insmod; do
+ if [ -L ${D}/sbin/${f} ]; then
+ ln -sf `ls -l ${D}/sbin/${f} | \
+ sed 's/.* -> //'`.old ${D}/sbin/${f};
+ fi;
+ mv ${D}/sbin/${f} ${D}/sbin/${f}.old;
+ done
+# make prefix=${D} move-old-targets || die "Renaming old bins to *.old failed"
+
+ einstall prefix=${D}
+
+ #create the new modprobe.conf
+ dodir /etc
+ ${S}/modules.conf2modprobe.conf /etc/modules.conf ${D}/etc/modprobe.conf || die "Could not create modprobe.conf"
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
+ #install the modules.conf2modprobe.conf tool, so we can update modprobe.conf.
+ into /usr
+ dobin ${S}/modules.conf2modprobe.conf
+
+}
+
+pkg_postinst() {
+ #Notify user of evilness, hope for a better way ;-)
+ echo ""
+ einfo "This overwrites the modutils files, so if you remove this,"
+ einfo "remember to remerge modutils. However, this package has"
+ einfo "installed a copy of the modutils files with suffix .old"
+ einfo "in your /sbin directory, which will automatically be used"
+ einfo "when needed."
+ echo ""
+}
+
+
+
+pkg_postrm() {
+ if [ "$(best_version ${PN})" == "${CATEGORY}/${PF}" -a ! -f /sbin/insmod ]; then
+ ewarn "Uninstalling module-init-tools has left you"
+ ewarn "without a modutils installtion. we recommend"
+ ewarn "emerging modutils immediately or remerging"
+ ewarn "module-init-tools."
+ fi
+}
+