summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-07-22 20:49:40 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-07-22 20:49:40 +0000
commit0ce67e6711b3240c4ffb3ce30d84fe1f6e91324f (patch)
treed8dcd6fdf9bcd62e27b46f0a0c602379d383ee54 /sys-apps/mlocate/mlocate-0.22.ebuild
parentVersion bump. (diff)
downloadhistorical-0ce67e6711b3240c4ffb3ce30d84fe1f6e91324f.tar.gz
historical-0ce67e6711b3240c4ffb3ce30d84fe1f6e91324f.tar.bz2
historical-0ce67e6711b3240c4ffb3ce30d84fe1f6e91324f.zip
test for usersandbox and userpriv in FEATURES is not needed anymore as upstream fixed the test suite, this cloes bug 278743 by bangert
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'sys-apps/mlocate/mlocate-0.22.ebuild')
-rw-r--r--sys-apps/mlocate/mlocate-0.22.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/sys-apps/mlocate/mlocate-0.22.ebuild b/sys-apps/mlocate/mlocate-0.22.ebuild
index 631b99b5c79a..3b6ae047e36c 100644
--- a/sys-apps/mlocate/mlocate-0.22.ebuild
+++ b/sys-apps/mlocate/mlocate-0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.22.ebuild,v 1.5 2009/06/11 19:57:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mlocate/mlocate-0.22.ebuild,v 1.6 2009/07/22 20:49:40 fauli Exp $
inherit eutils
@@ -21,12 +21,12 @@ pkg_setup() {
}
src_compile() {
- econf || die "econf failed"
- emake groupname=locate || die "emake failed"
+ econf || die
+ emake groupname=locate || die
}
src_install() {
- emake groupname=locate DESTDIR="${D}" install || die "emake install failed"
+ emake groupname=locate DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README NEWS
insinto /etc
@@ -49,14 +49,6 @@ src_install() {
keepdir /var/lib/mlocate
}
-src_test() {
- if has userpriv ${FEATURES} && ! has usersandbox ${FEATURES}; then
- make check-local || die "test suite failed"
- else
- ewarn "Activate FEATURES=userpriv and deactivate FEATURES=usersandbox to run testsuite."
- fi
-}
-
pkg_postinst() {
elog "Note that the /etc/updatedb.conf file is generic"
elog "Please customize it to your system requirements"