summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-11 18:19:24 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-11 18:19:24 +0000
commitfda42c74149caea1eeee70d425f63e91cb969665 (patch)
tree598323b39470ff3aefec7d49c0b69fa91f01687c /sys-apps/mkisofs
parentInitial version. Closes #2504. (diff)
downloadhistorical-fda42c74149caea1eeee70d425f63e91cb969665.tar.gz
historical-fda42c74149caea1eeee70d425f63e91cb969665.tar.bz2
historical-fda42c74149caea1eeee70d425f63e91cb969665.zip
- Added explicit src_compile() function, because otherwise failed
compilation did not prevent the ebuild process from continuation. This closes bug #2488. - Made DIR function in src_install() local.
Diffstat (limited to 'sys-apps/mkisofs')
-rw-r--r--sys-apps/mkisofs/ChangeLog11
-rw-r--r--sys-apps/mkisofs/mkisofs-1.13-r2.ebuild14
2 files changed, 15 insertions, 10 deletions
diff --git a/sys-apps/mkisofs/ChangeLog b/sys-apps/mkisofs/ChangeLog
index 731f81e2c5eb..3150af21b781 100644
--- a/sys-apps/mkisofs/ChangeLog
+++ b/sys-apps/mkisofs/ChangeLog
@@ -1,13 +1,10 @@
# ChangeLog for sys-apps/mkisofs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkisofs/ChangeLog,v 1.1 2002/02/01 21:53:37 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkisofs/ChangeLog,v 1.2 2002/05/11 18:19:24 agenkin Exp $
*mkisofs-1.13-r2 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ 11 May 2002; Arcady Genkin <agenkin@thpoon.com> mkisofs-1.13-r2.ebuild :
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ Added explicit src_compile function. No user-visible changes. This
+ closes bug 2488.
diff --git a/sys-apps/mkisofs/mkisofs-1.13-r2.ebuild b/sys-apps/mkisofs/mkisofs-1.13-r2.ebuild
index bef3b34fb008..b06094b2f2de 100644
--- a/sys-apps/mkisofs/mkisofs-1.13-r2.ebuild
+++ b/sys-apps/mkisofs/mkisofs-1.13-r2.ebuild
@@ -1,17 +1,25 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkisofs/mkisofs-1.13-r2.ebuild,v 1.3 2002/05/05 17:54:58 daybird Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mkisofs/mkisofs-1.13-r2.ebuild,v 1.4 2002/05/11 18:19:24 agenkin Exp $
# -r2 by Dan Armak
-S=${WORKDIR}/${P}
DESCRIPTION="Premastering program for creating iso9660 volumes"
-SRC_URI="ftp://ftp.fokus.gmd.de/pub/unix/cdrecord/mkisofs/${P}.tar.gz"
HOMEPAGE="http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/mkisofs.html"
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.fokus.gmd.de/pub/unix/cdrecord/mkisofs/${P}.tar.gz"
+
+src_compile() {
+
+ emake || die
+
+}
+
src_install() {
into /usr
+ local DIR
#looks like these are no longer used
[ -d mkisofs/OBJ/i686-linux-cc ] && DIR=i686-linux-cc