summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-09 08:21:12 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-09 08:21:12 +0000
commit9eadd7e588f74cb747e03d0c36acb6ddafdedc23 (patch)
treed3e249a0e0f4d6200b34a0b9c30fce28e42f452e /sys-apps/memtest86
parentold (diff)
downloadhistorical-9eadd7e588f74cb747e03d0c36acb6ddafdedc23.tar.gz
historical-9eadd7e588f74cb747e03d0c36acb6ddafdedc23.tar.bz2
historical-9eadd7e588f74cb747e03d0c36acb6ddafdedc23.zip
Version bump #285284 by Sergey Kondakov.
Package-Manager: portage-2.2_rc42/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog8
-rw-r--r--sys-apps/memtest86/files/memtest86-3.5-build.patch23
-rw-r--r--sys-apps/memtest86/memtest86-3.5.ebuild52
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index d95d7e0d5f11..9c6afdba4628 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/memtest86
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.35 2009/03/22 21:30:38 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.36 2009/10/09 08:21:12 vapier Exp $
+
+*memtest86-3.5 (09 Oct 2009)
+
+ 09 Oct 2009; Mike Frysinger <vapier@gentoo.org> +memtest86-3.5.ebuild,
+ +files/memtest86-3.5-build.patch:
+ Version bump #285284 by Sergey Kondakov.
22 Mar 2009; Michał Januszewski <spock@gentoo.org> memtest86-3.3.ebuild,
memtest86-3.4.ebuild:
diff --git a/sys-apps/memtest86/files/memtest86-3.5-build.patch b/sys-apps/memtest86/files/memtest86-3.5-build.patch
new file mode 100644
index 000000000000..ada8f4e909ac
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-3.5-build.patch
@@ -0,0 +1,23 @@
+make sure all the flags in question force i386 and disable SSP
+
+--- Makefile
++++ Makefile
+@@ -10,6 +10,5 @@
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC $(SMP_FL)
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
+
+@@ -28,3 +27,3 @@
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+@@ -55,3 +54,3 @@
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
diff --git a/sys-apps/memtest86/memtest86-3.5.ebuild b/sys-apps/memtest86/memtest86-3.5.ebuild
new file mode 100644
index 000000000000..0890313e8446
--- /dev/null
+++ b/sys-apps/memtest86/memtest86-3.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.5.ebuild,v 1.1 2009/10/09 08:21:12 vapier Exp $
+
+inherit mount-boot eutils toolchain-funcs
+
+DESCRIPTION="A stand alone memory test for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="http://www.memtest86.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.5-build.patch #66630
+
+ if use serial ; then
+ sed -i \
+ -e '/^#define SERIAL_CONSOLE_DEFAULT/s:0:1:' \
+ config.h \
+ || die "sed failed"
+ fi
+
+ tc-export AS CC LD
+}
+
+src_install() {
+ insinto /boot/memtest86
+ doins memtest.bin || die "doins failed"
+ dodoc README README.build-process
+}
+
+pkg_postinst() {
+ einfo
+ einfo "memtest.bin has been installed in /boot/memtest86/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+ einfo " - For grub: (replace '?' with correct numbers for your boot partition)"
+ einfo " > title=Memtest86"
+ einfo " > root (hd?,?)"
+ einfo " > kernel /boot/memtest86/memtest.bin"
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86/memtest.bin"
+ einfo " > label = Memtest86"
+ einfo
+}