summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-02 03:22:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-02 03:22:10 +0000
commit25b5f9f5dfa729992ff380abaa61f2b0a05c5150 (patch)
tree5e8f6026819f3d20e4514bdf2ecc09965c24f6ca /sys-apps/man
parentMark alpha/ia64/s390/sh stable #348549. (diff)
downloadhistorical-25b5f9f5dfa729992ff380abaa61f2b0a05c5150.tar.gz
historical-25b5f9f5dfa729992ff380abaa61f2b0a05c5150.tar.bz2
historical-25b5f9f5dfa729992ff380abaa61f2b0a05c5150.zip
old
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/files/man-1.6f-man2html-compression.patch54
-rw-r--r--sys-apps/man/files/man-1.6f-so-search.patch34
-rw-r--r--sys-apps/man/man-1.6f-r3.ebuild127
3 files changed, 0 insertions, 215 deletions
diff --git a/sys-apps/man/files/man-1.6f-man2html-compression.patch b/sys-apps/man/files/man-1.6f-man2html-compression.patch
deleted file mode 100644
index ae059d3aedc3..000000000000
--- a/sys-apps/man/files/man-1.6f-man2html-compression.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-add support for bzip2/lzma to man2html and friends
-
---- man2html/glimpse_filters
-+++ man2html/glimpse_filters
-@@ -1,3 +1,5 @@
-+*.bz2 bzip2 -d -c
-+*.lzma lzma -d -c
- *.gz gzip -d -c
- *.Z gzip -d -c
-
---- man2html/scripts/cgi-bin/man/man2html
-+++ man2html/scripts/cgi-bin/man/man2html
-@@ -93,6 +93,9 @@
- *.bz2)
- bzcat "$PAGE" | "$MAN2HTML" "$LL" -D "$PAGE"
- ;;
-+ *.lzma)
-+ lzcat "$PAGE" | "$MAN2HTML" "$LL" -D "$PAGE"
-+ ;;
- *)
- "$MAN2HTML" "$LL" "$PAGE"
- ;;
-@@ -103,6 +106,9 @@
- elif [ -r "$PAGE".bz2 ]
- then
- bzcat "$PAGE".bz2 | "$MAN2HTML" "$LL" -D "$PAGE"
-+elif [ -r "$PAGE".lzma ]
-+then
-+ lzcat "$PAGE".lzma | "$MAN2HTML" "$LL" -D "$PAGE"
- else
- "$MAN2HTML" -E "Strange... Cannot find (or read) $PAGE."
- fi
---- man2html/scripts/cgi-bin/man/mansearch
-+++ man2html/scripts/cgi-bin/man/mansearch
-@@ -153,7 +153,7 @@
- }
- print "<DT> <a href=\"" cgipath "/man2html?" fullname "\">";
- textname = filename;
-- sub(/\.(gz)|Z|z$/, "", textname);
-+ sub(/\.([zZ]|gz|bz2|lzma)$/, "", textname);
- sub(/\./, "(", textname);
- textname = textname ")";
- print textname;
---- man2html/scripts/cgi-bin/man/mansec
-+++ man2html/scripts/cgi-bin/man/mansec
-@@ -128,7 +128,7 @@
- # Print out alphabetic quick index and other links
- }
- # Split page.n into "page" and "n" and generate an entry
-- sub(/[.]([zZ]|(gz))$/, "", manpage);
-+ sub(/[.]([zZ]|gz|bz2|lzma)$/, "", manpage);
- match(manpage, /[.][^.]+$/);
- title = substr(manpage, 1, RSTART - 1);
- if (section != "all") {
diff --git a/sys-apps/man/files/man-1.6f-so-search.patch b/sys-apps/man/files/man-1.6f-so-search.patch
deleted file mode 100644
index d9d4af4fe346..000000000000
--- a/sys-apps/man/files/man-1.6f-so-search.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-improve the uncompressed .so search
-
---- a/src/man.c
-+++ b/src/man.c
-@@ -381,13 +381,23 @@ again:
- }
- /*
- * Some people have compressed man pages, but uncompressed
-- * .so files - we could glob for all possible extensions,
-- * for now: only try .gz
-+ * .so files - we should discover this list dynamically, but
-+ * for now just hardcode it.
- */
-- else if (fp == NULL && get_expander(".gz") &&
-- strlen(name)+strlen(".gz") < BUFSIZE) {
-- strcat(name, ".gz");
-- fp = fopen (name, "r");
-+ else if (fp == NULL) {
-+#define ARRAY_SIZE(a) (sizeof(a) / sizeof(*(a)))
-+ size_t i, name_len = strlen(name);
-+ const char *extensions[] = { ".gz", ".bz2", ".lzma", ".z", ".Z" };
-+ for (i = 0; i < ARRAY_SIZE(extensions); ++i) {
-+ const char *comp = extensions[i];
-+ name[name_len] = '\0';
-+ if (get_expander(comp) && name_len+strlen(comp) < BUFSIZE) {
-+ strcat(name, comp);
-+ fp = fopen(name, "r");
-+ if (fp)
-+ break;
-+ }
-+ }
- }
-
- if (fp == NULL) {
diff --git a/sys-apps/man/man-1.6f-r3.ebuild b/sys-apps/man/man-1.6f-r3.ebuild
deleted file mode 100644
index 14099c6b531d..000000000000
--- a/sys-apps/man/man-1.6f-r3.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6f-r3.ebuild,v 1.14 2010/01/27 02:31:10 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Standard commands to read man pages"
-HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
-SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="lzma nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="|| ( >=sys-apps/groff-1.19.2-r1 app-doc/heirloom-doctools )
- !sys-apps/man-db
- !app-arch/lzma
- lzma? ( || ( app-arch/xz-utils app-arch/lzma-utils ) )"
-PROVIDE="virtual/man"
-
-pkg_setup() {
- enewgroup man 15
- enewuser man 13 -1 /usr/share/man man
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/man-1.6f-man2html-compression.patch
- epatch "${FILESDIR}"/man-1.6-cross-compile.patch
- epatch "${FILESDIR}"/man-1.5p-search-order.patch
- epatch "${FILESDIR}"/man-1.6f-unicode.patch #146315
- epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
- epatch "${FILESDIR}"/man-1.6b-more-sections.patch
- epatch "${FILESDIR}"/man-1.6c-cut-duplicate-manpaths.patch
- epatch "${FILESDIR}"/man-1.5m2-apropos.patch
- epatch "${FILESDIR}"/man-1.6d-fbsd.patch
- epatch "${FILESDIR}"/man-1.6e-headers.patch
- epatch "${FILESDIR}"/man-1.6f-so-search.patch
- epatch "${FILESDIR}"/man-1.6f-compress.patch
-
- strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
-}
-
-src_compile() {
- unset NLSPATH #175258
-
- tc-export CC BUILD_CC
-
- local mylang=
- if use nls ; then
- if [[ -z ${LINGUAS} ]] ; then
- mylang="all"
- else
- mylang="${LINGUAS// /,}"
- fi
- else
- mylang="none"
- fi
- if use lzma; then
- mycompress=/usr/bin/lzma
- else
- mycompress=/bin/bzip2
- fi
- COMPRESS=$mycompress \
- ./configure \
- -confdir=/etc \
- +sgid +fhs \
- +lang ${mylang} \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- unset NLSPATH #175258
-
- emake PREFIX="${D}" install || die "make install failed"
- dosym man /usr/bin/manpath
-
- dodoc LSM README* TODO
-
- # makewhatis only adds man-pages from the last 24hrs
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/makewhatis.cron makewhatis
-
- keepdir /var/cache/man
- diropts -m0775 -g man
- local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
- for x in ${mansects//:/ } ; do
- keepdir /var/cache/man/cat${x}
- done
-}
-
-pkg_postinst() {
- einfo "Forcing sane permissions onto ${ROOT}var/cache/man (Bug #40322)"
- chown -R root:man "${ROOT}"/var/cache/man
- chmod -R g+w "${ROOT}"/var/cache/man
- [[ -e ${ROOT}/var/cache/man/whatis ]] \
- && chown root:0 "${ROOT}"/var/cache/man/whatis
-
- echo
-
- local f files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
- for f in ${files} ; do
- [[ ${f} == */etc/cron.daily/makewhatis ]] && continue
- [[ $(md5sum "${f}") == "8b2016cc778ed4e2570b912c0f420266 "* ]] \
- && rm -f "${f}"
- done
- files=$(ls "${ROOT}"etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
- if [[ ${files/$'\n'} != ${files} ]] ; then
- ewarn "You have multiple makewhatis cron files installed."
- ewarn "You might want to delete all but one of these:"
- ewarn ${files}
- fi
-
- if has_version app-doc/heirloom-doctools; then
- ewarn "Please note that the /etc/man.conf file installed will not"
- ewarn "work with heirloom's nroff by default (yet)."
- ewarn ""
- ewarn "Check app-doc/heirloom-doctools elog messages for the proper"
- ewarn "configuration."
- fi
-}